Welcome HOME to SatelliteGuys! We are America's Most Popular Satellite Forum!

        

Results 1 to 4 of 4

Thread: Roku wireless - if you can't connect

  1. #1
    Help Keep SatelliteGuys For All, Click a Star and Become a Supporter! Tampa8 did! Help Support The Site And Get Rid of the Syndicated Ads, Tampa8 did! If you enjoy the site consider supporting it, Tampa8 did! Be COOL like Tampa8 and Click a Star and become a Supporting Pub Member today!
    Join Date
    Sep 8th, 2003
    Location
    Tampa/Eastern Ct
    Posts
    8,181
    Post Thanks / Like

    Roku wireless - if you can't connect

    The Roku will connect easily most of the time with many routers. As always if not you have to do the normal check list of things, like making sure you don't have MAC address set to accept only the devices listed, or that you are actually typing in the passcode correctly..



    But there is a problem that appears to be distinctly with Roku only on very few routers, Actiontec or some models of Actiontec being one.

    The Roku will see your router, it reads the SSID, but when you try to connect it fails. There are all sorts of fixes people have posted, like making sure ping is turned on, or that the router is set to "share" not "open." None of those is the problem normally.
    For some reason on those very limited routers the Roku will not connect if the Router's gateway last number is set to "1" - meaning 192.168.1.1\ Unfortuneatly that is the normal way routers are configured. While other devices don't seem to have the problem, the Roku, or at least the Roku 2 XD does.

    Therfore you need to change the Gateway to 192.168.1.2 - or 3 or 4. I used 4 and it worked immediately. Keep in mind if you have other wireless devices attached, they may now need to be reset to connect. Some of them may not, on their own try anything but the default gateway. You would then need to go into that device and change the settings to look for the gateway number you picked. Examples of devices that you would need to change is the Slingbox, or security cameras. Wireless smartphones should find it, but even some of them you may have go into settings and find where you can pick the gateway number.

    Hopefully this will help someone somewhere.

  2. # ADS
    Register Today & This Ad Goes Away! Syndicated Advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

    Reigster at SatelliteGuys
     
  3. #2
    Join Date
    Jun 19th, 2010
    Location
    Virgin Islands
    Posts
    496
    Post Thanks / Like
    I don't think your fix is applicable to everyone. My Linksys 54G router is set to 192.168.1.1 it assigns IPs in the range 192.168.1.100 - 119 and I have never had a problem with my Roku connecting and streaming.
    VIP 211K w/external hard drive
    VIP 211 w/external hard drive
    Toshiba LCD HDTV
    LG LCD HDTV
    Slingbox Solo
    Dish 500 for 110/119

  4. #3
    Help Keep SatelliteGuys For All, Click a Star and Become a Supporter! Tampa8 did! Help Support The Site And Get Rid of the Syndicated Ads, Tampa8 did! If you enjoy the site consider supporting it, Tampa8 did! Be COOL like Tampa8 and Click a Star and become a Supporting Pub Member today!
    Join Date
    Sep 8th, 2003
    Location
    Tampa/Eastern Ct
    Posts
    8,181
    Post Thanks / Like
    Thread Starter
    My exact words;

    The Roku will connect easily most of the time with many routers.
    But there is a problem that appears to be distinctly with Roku only on very few routers, Actiontec or some models of Actiontec being one.

  5. #4
    Join Date
    Sep 8th, 2003
    Location
    Twin Cities, MN
    Posts
    731
    Post Thanks / Like
    Quote Originally Posted by Tampa8 View Post
    But there is a problem that appears to be distinctly with Roku only on very few routers, Actiontec or some models of Actiontec being one.
    I wish I had one of those so I could figure out what is going on. My guess is the issue is related to other settings with such a router, but they change when you change what you mentioned. Wifi is pretty basic in general. It should just work.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •