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Click a Topic: Remote Control Shortcuts Recording Tips More Power!
Setup Tips Power User Tips  Workarounds
» - Undocumented feature Lt - New Key tips

REMOTE CONTROL SHORTCUTS

- Changes the “source” (HD DVR, DVR, etc.) signal to watch on your TV

- Cycles through screen resolution options. »Press & hold for Native On/Off.

SLIDE SWITCH - Changes remote to control other equipment, for example, a DVD

- Power turns your HR-20 Plus HD DVR or other equipment on and off, as selected with MODE switch
TV POWER - Turns your TV and HR-20 Plus HD DVR on and off

Cruise Controls (formerly know as Trick Play) |GRAY means this feature is not labeled on the Remote Control.

[=]STOP - In recorded TV, stops playback. »Inthe To Do List, [«] STOP deletes an item.
@ REPLAY - Jumps back 6 seconds and plays video from that location
[BEGIN - Press and hold @ for 3 seconds to jump to the beginning (or previous bookmark if set)
[«] REWIND - Press up to 3 times to increase speed
P JUMP € |- Press and hold [«] to jump back to previous tick mark (usually 15 or 30 minutes).
[ |PAUSE - Pauses curent video. Press PAUSE in the GUIDE or LIST to freeze the Picture in List.
|[FRAME - - Press [1I] PAUSE and then [w] - FFWD to go forward one frame at a time
FRAME € |- Press [1I] PAUSE and then [«] - REWIND to go back one frame at a time
ADVANCE - (Slip) Jumps ahead in a recording - 30 second Slip in 1% seconds. Press up to 20 times in a row!
[END - Press and hold E for 3 seconds to jump to end of program (or next bookmark if set)
[»] PLAY - Play video. » Also the Where Am | button (Time Bar). Press to clear the time bar.
SLOW - Press and hold [»] for slow motion (like the old SLOW motion button)
RECORD - Records current program. Press RECORD twice to record this program and future shows. (Series Link)

[»] FFWD - B Fast Forward is 5, 12, 20, or 90 times normal speed!
> JUMP > - Press and hold [»] FFWD to jump to next tick mark Skip is 300 times normal speed!.

Guide Buttons

- Press once to see Channel Categories. Press twice to see the onscreen program Guide.

- Access the Active™ Channel - local weather and more! P Interactive Channels: 102 & 104

- Displays My Playlist (Also known as "My Video on Demand" or "Now Playing List")

- Clears menu & returns to last channel. Also removes the time bar from the screen! Like old |Live TV | button.

A>v <) ARROWS - Move highlight to items in whatever direction needed
SELECT] - Selects the highlighted item

- Go to previous screen. - Press twice in recording playback: go where you were in My Playlist
[MENU] - Displays Quick Menu of settings and services (previously know as TiVo Button & TiVo Central)
- Displays information about a program. »Press & Hold for hotlink to System Info screen.

e RED - In Guide, jumps 12 hours back. »In Search Results, jumps 90 minutes back.

® GREEN - In Guide, jumps 12 hours forward. P In Search Results, jumps 90 minutes ahead.

B YELLOw - For TV, switches alternate audio. » For Music & Photos, jumps between Music & Photos.

e BLUE - For live TV, displays the Mini Guide; other functions vary, in My Playlist marks program to be saved.

Volume & Channel

+ VoL - Raises or lowers volume - Turns sound volume on/off
[CHAN 4], - In live TV, changes channel up or down. In a menu, such as the Guide, pages up or down
PREV] - Tunes to last channel viewed. Great for jumping back and forth between two live shows.

NUMBER KEYS - Tune to a channel directly; also input numbers when needed in onscreen menus;
[-]DASH - Press twice to delete a show in your My Playlist list. (formerly known as Clear button)
- Activates channel number entries quickly
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SETUP TIPS
> INSTALLATION TIPS - Click here for 30 Undocumented: Installation Tips

X » GUIDE BUTTON - Make the button bring up the Guide instead of Category Choices.
Press [MENU], click Help & Settings - Click Setup > Click Display - Scrolling Effects > Select > Off

X » GO FASTER! - Turn of the Scrolling effects to speedup the Guide and menus!
Press [MeENU], click Help & Settings - Click Setup - Click Display > Guide Keypress > Select > Grid Guide First

DISPLAY OPTIONS - Only HDMI & Component (Y Pb Pr) connections are HD. S-Video & RCA Video are not HD!
Press [MeENU] then click Help & Settings - Click Setup = Click Display and then choose your settings:
» NATIVE Off - You set the format for faster channel changes.
BANNER TIME - 2, 4, or 6 second display of banners & time bar. clears these early.
HDTYV - Press the e GREEN button for Resolutions. Set the TV’s resolutions that your TV can display.
» Only select the resolutions you really need to speed up channel switching time.
- Cycles through screen formats. » Slow. Press & hold for Native On/Off.

CLOSED CAPTIONING - » Press [MENU]| = Help & Settings - Setup - Display - Closed Captioning
» Set Closed Caption On/Off, Font, Size, Color, and Background Color.
» Set Closed Captioning to Service 1 or you will see no Closed Captioning.
»To turn CC right back off, press to go to the last menu you were in!

SETUP YOUR OWN CUSTOM CHANNELS LIST - To see only the channels you receive and like in the Guide.
Press [ MENU] > Favorites > Edit Settings > either Custom 1 or Custom 2 to customize
channels. Press the e Green Button. Name your List & Save. Click your Channel list to make it the default
P If you have two of the same channel number the first is HD and the second SD.

SETUP YOUR REMOTE CONTROL - Your DirecTV remote can also control your TV, Stereo, and DVD player.
Press [MENU], then click Help & Settings - Settings > Remote. Follow the onscreen instructions.
» Click IR/RF Setup above to use RF! RF works behind a wall or cabinet doors.

DOLBY® SOUND » Dolby 5.1 Surround Sound may be OFF by default!
Turn Surround Sound ON - Press [ MENU], click Audio Options = Edit Settings—> Click Dolby ON
» Verify that you have 5.1: Tune to channel HDNet 79. It always broadcasts in 5.1.
If the sound and picture are out of synch, try this: Press [LisT|then or try changing channels.

» Sound Effects - Press [MENU] > Help & Settings > Setup - Display = Sound Effects
» Choose the volume level for the error sound or turn it off.

PARENTAL CONTROLS (“Locks and Limits”) To block channels, limit spending, or hours per day:
Press [MENU] - Press twice > Click Parental Controls - Click Edit Settings
Unlock for 4 Hours: Press [MENU] and then click Parental Controls = Unlock 4 Hours
» Parental Controls will also block Titles and Description of MA rated programs!
» Unlock another 4 Hours: Press [ MENU] and then click Parental Controls - Extend 4 Hours

X¥ »SHOW ONLY HD CHANNELS - Press [GUIDE]|[GUIDE] | CHAN Y|[SELECT].

» SURGE SUPPRESSORS & UPS (Uninterruptible Power Supply, Battery Backup)
Important! Use a UPS with surge suppression for all PCs, TVs, DVRs, etc. A power dip can ruin a recording.
The UPS also protects the phone line input. Make sure your UPS is rated for at least 500 Joules & 500 V-A

» REMOTE SETUP - Detailed instructions: http://www.directv.com/see/pdf/RC32.pdf

»WATCH ONE HD DVR+ ON MULTIPLE TVS
» Connect two or more TVs to the HD DVR+ outputs up to 25’ or more away.
»Use 720p or 1080i Stretch Format so 480i on S-Video or Composite (RCA) is not distorted.
» Watch your HD DVR+ throughout your house: Connecting Multiple TVs To The HD DVR+

GET HELP - Press [ MENu] - Help & Settings = Help Call: Customer Support: 800-531-5000



http://www.dbstalk.com/showthread.php?p=694781#post694781
http://www.directv.com/see/pdf/RC32.pdf
http://www.dbstalk.com/showthread.php?t=75894
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RECORDING TIPS

SEARCH TIPS - To find programs, start in the Guide: Press twice. Press to watch a show.

Jump 12 hours - Press the e RED or e GREEN buttons to jump 12 hours ahead or back.

Hidden Option! -Search by Channel - In the Guide, Press <1 LEFT ARROW to highlight the channel label
Press [INFo]for a listing of the next 14 days for this one channel! (It takes about 20 seconds.)

Search by Title, Channel, or Date - Press [MENU] & Search - Title, Channel, or Date/Time

¥t » Skip Special Characters for Keyword search. For instance use “CSI NY” for “CSI: NY”

P Search results with a “<” in front of them are on right now.

» Repeat a Search - Press [MEnu] = Click Search - Select the Search to Repeat.
P Delete a Search - After the search runs you will have the option to Delete.

> Search & Autorecord may record channels you do not get! - See Workarounds for help.

CATEGORY SEARCH - Press twice then [ MEnu] & then Click Category. You can then choose from:
¢ Movies ¢ Sports ¢ Themes ¢ Types ¢ MPAA Rating ¢ Audio & Video ¢ Language ¢ and more!
For instance, use Type to find Award Shows, Movies for Horror Movies, or Audio & Video for Dolby or HD.
Press the ® GREEN or e RED button to jump ahead or back 90 minutes in your Search Results!

RECORD - Press . » Press ->[seLecT] 2 Rec. Once for options.
SERIES LINK "Season Pass" - Press |® | twice. P Press ->[seLEcT] 2> Rec. Series for options.
Press |®] a third time to cancel record
EDIT RECORDING OPTIONS - Highlight the program, press - [ yELLOW button > the program
Click Rec. Once or Record Series. Options: Start early or Stop later, etc.
P Suspend - Have just the last show waiting: set First Run Only and to only save 1 Episode
» What Am | Recording? - Press[LisT|to see what you are recording.

» MANUAL RECORD - Press then Press the [§ YELLow button and Click Scheduler > Manual.
» Record A Block Of Shows or a marathon for instance from 7:00 to 10:00.
» Record One Show A Day (say 1 of a series or news programs repeated all day.)
» Negative Padding - Manual Recording can start a recording later or end earlier.

AUTORECORD - (a.k.a. WISHLISTS - Record all broadcasts on all channels) These show as an ®* in the Guide.

Press [ MENU] & Click Search > Keyword (or Person) - Enter the word - Click Continue - Autorecord
» Autorecord is broken for Title Search. You can still do a Series Record however.

MY PLAYLIST - Press - "Now Playing List", highlight a program, Press ->[seLEcT] to Play, Delete, etc.
Delete - Press [-] DAsSH twice to quickly delete a recording

Mark & Delete - Press [menu] then click Mark & Delete to delete several recorded shows at once
Keep - Highlight program, Press e BLUE button. » Keep is shown as: @
» Unwatched programs are in white, »Watched programs are in gray.
» Groups are in italics, » Shows soon to be deleted have this symbol: &
Xt P Group Play- Select folder, click [pLay]. 3 »Group Delete-Select folder, click [PLAY].
» SORT LISTINGS - Press [MENU] & click List By - Title, Date, Channel, etc. or open all Groups.
» Press twice to go where you left off in. Press for the first entry.
» Where Am 1? - Press [»] PLAY to see the time bar. Press - to clear the time bar.
» Don’t Show Me - Press [i1] to freeze the Picture in List so your show pauses.

TO DO LIST — Shows what programs are scheduled to record. Press and then the [§ YELLow button.
» Quick Delete - Highlight a To Do item & Press [«] STOP once. Thank you: mtnagel!
» Conflicts - %2 means a show won’t record. You can cancel one of the three overlapping shows.

RECORD DEFAULTS - Lets you set your default recording settings: First Run, Start Early, Stop Later, etc.
Press [LisT), [] YELLOW button, & Select any show. Click Rec. Once, Press [MENu], & then click Record Defaults.

» CHECK LIVE TV WHILE WATCHING A RECORDING
While playing a recorded show Press to see up to the last 90 minutes of live TV.
» If you haven’t changed channels, Press to go back, otherwise press > [»]PLAY.
» Oops Button - If you accidentally stop a recording, Press to go back to where you left off.
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POWER USER TiIPS!
»TiVo - To help with your transition from TiVo, click the TiVo to HR-20 Survival Guide

» PREVIOUS CHANNELS - Press [MENU | > Previous Ch’s to go to a recently viewed channels

RECORD TO DVD or VCR - The key is that all outputs are on at the same time!
» Unplug the HD DVR+ phone line or turn of Notifications. Turn on the VCR or DVD Recorder and hit pause.
Press then Use the AV ARROWS & a recording.
» Click Play, & press [ Il | PAUSE right away.
» Press to display show information.
» Un-pause the VCR or DVD Recorder to let it begin recording with the show information.
On the HR-20, Press E PLAY. Do not change channels or press remote buttons until the recording is complete.

TO DO LIST - To see what you have scheduled to record: Press and then press the [§ YELLow button

INTERACTIVE CONTENT - You can interactively watch up to 8 channels at once!
» From the Guide or Mini Guide, choose a MIX Channel: NEWSMIX: 102 SPORTSMIX: 104
P> Use the A >V <1 ARROW keys to highlight which audio you want to hear
» Press to go to a channel and then Press [PREv]to go back to the MIX Channel

WHAT'S HOT - Is real-time, interactive ratings. Choose from the hottest 50 shows at this instant!
» Go to 1 0 4 [ENTER]. Press the e RED button when that option becomes available.
» Use the <> ARROW keys to move through Top 10 Lists: Local, Nation, Movies, Sports, and Kids
P> Use the A vV ARROW keys to select a program.
» Press to watch it. Press to return to SPORTSMIX.

MINI GUIDE - Press the e BLUE button. Press A v to move, press to choose a show, |® | RECORD to record

»BOOKMARKS - Jump back to a play or a scene to later. Press if you are in live TV.
» SET a Bookmark in a recording: Press [ Il |PAUSE = e GREEN key - [ Il | PAUSE
» DELETE a Bookmark: Press [MENU] > Bookmarks > Select bookmark, Press DASH twice.
» Press and hold [w] FFWD or IEI REWIND to JUMP to the next or previous Bookmarks.

SLINGBOX - AV or Pro from www.slingbox.com
» CONTROL Your HD DVR+ over the internet or from some cell phones.
»WATCH Your HD DVR+ over the internet on a pc or laptop in another room or city.

HR20 Only Local “Off-Air” Broadcast Channels - Connect your TV antenna to the OFF-AIR IN input, manual p. 65.
Initial Setup: [MENU] - click Help & Settings - Setup - Sat & Ant > Antenna Setup - Initial Setup > Enter Zip
Select your Primary Local Area. Option: Click Secondary Local if you receive channels from another area.
» Edit Off-Air Channels remove or add local HD channels to your Guide.
» Signal Strength - you need 50%+ for a solid signal unless you have multipath. Click here for more help.
» Reset Off-Air Channels let’s you start over and do a new Initial Setup.

» Remember to add your HD local channels to your Favorites Lists (Custom Channels)
» When tuning to a local HD channel, remember the Dash. For 5.1 press: @Em

> Record Two Programs While Watching A Live Local Broadcast
Split the Local HD to your HD DVR+ and TV so you can record 2 programs while watching a 3" local channell!

» External Hard Drive - Use a large external eSATA hard drive instead of the one built in!
The manual p. 7 says "for future use." This forum made it work: http://www.dbstalk.com/showthread.php?t=66201
Users have discussed eSATA drives like these: Seagate 500GB, Seagate 750, Calvary 750 GB

» CONTROL ONE HD DVR+ WITH TWO REMOTES - Even through walls in another room!
Setup a 2"! DIRECTV Remote Control: Press [MENU], click Help & Settings—> Settings >Remote>IR/RF> RF

» CONTROL TWO HD DVR+'s WITH ONE REMOTE — Thank you: thekochs.
Cover DVR #2's front panel. Setup DVR #1. Uncover DVR #2 & cover DVR #1. Set Remote slider to AV1.
Press [MENU] > Help & Setup - Setup > Remote > Receiver. (Code 00003). AV1 Now controls DVR #2!



http://www.dbstalk.com/showthread.php?t=69404
http://www.slingbox.com/
http://www.dbstalk.com/showthread.php?p=817199#post817199
http://www.dbstalk.com/showthread.php?t=66201
http://www.amazon.com/Seagate-FreeAgent-Desktop-External-ST305004FDA1E1-RK/dp/B000ND75C0/ref=pd_bbs_sr_1/002-6192710-1984800?ie=UTF8&s=electronics&qid=1186170286&sr=8-1
http://www.amazon.com/Seagate-FreeAgent-FireWire-External-ST307504FPA1E3-RK/dp/B000NDBRKG/ref=pd_bbs_sr_4/002-6192710-1984800?ie=UTF8&s=electronics&qid=1186170286&sr=8-4
http://www.newegg.com/Product/Product.asp?Item=N82E16822101036
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MORE POWER!
» Updated Owners Manual - Click for the latest searchable manual: HR-20 Owners Manual

> ENJOY YOUR PHOTOS & MUSIC - From your PC: HD DVR+ Networking Tips

» Automatic Tuning - Have a program coming up? You can automatically change programs!
In the Guide, highlighted an upcoming program you don’t want to miss then press RECORD.
» If both tuners are busy, the HD DVR+ asks if you want to change channels 2 minutes before
recording a different channel! When the program is over, you will be asked if you want to keep a recording!

EXTENDING TIME (PADDING) - Shows often run earlier or later than scheduled.
Normal Padding - Press[LisT]then Press the [§ YELLow button and then the program
You can choose to “pad”: Start early or Stop later, etc. Click "Record as Set" or "Record Series".
» Soft Padding - Is automatic! If you extend a first show a few minutes longer and start the next show a few
minutes early - on two channels. My Playlist looks like four shows are recording at once!

INFO (Previously known as Display)
Press to see information. Click More Info for more information. »Press to clear Info.
Press [»] Play to see the Time Bar. »Press to clear the time bar.

» PRIORITIZER - Press - @ YELLOW button = Click Prioritizer ("Season Pass Manager")
Decides which program to record based upon the priority you assign. Top priorities are low numbers.
» To change the priority - Select the season pass. Press A or V to move.
» Delete a Series (Season Pass), highlight the season pass in the Guide & press [-] DASH twice

FIRST RUNS ONLY - To only record First Run shows (or only Repeats, or Both):
> Warning - Due to the Wrong Info Bug, it is best to record Both and delete Repeats manually
Press > Press the [§ YELLow button and then Click Prioritizer
Press to select the show, then Click Record
Press the e GREEN key and then Click Episode - First Run

RECORDING CONFLICTS
» This symbol in the Guide % means a program won't record. Two others have higher priorities.
Press[LIST]. then Press the B veLLow button and then click Prioritizer. Make this show be a higher priority.

SOFTWARE VERSION UPGRADE - New software upgrades when available should happen automatically overnight.
» To see what software version you have,
Press [ MENuU] then click Help & Settings > Setup - Info & Test
Press the Down ArrowV to move down to Software Version
» To force a software update: Open the HD DVR+ right front panel door & press the red Reset button.
After the blue screen first appears & the LEDs start circling, slowly press 0 2 4 6 8 on the remote once.
Nothing may happen for a while. Be patient.

DIM THE FRONT PANEL RING LEDS
On the HR-20 front panel, press the Left <] and Right > arrows at the same time
First Press - 90% Brightness Third Press > 70% Brightness
Second Press > 80% Brightness Fourth Press > LED's OFF
» Update Alert: Dim your LEDs. After an update, they will be bright again! Thank you: dougsmith

DESPERATE MEASURES - Three things to try...
UNPLUG - Press[oFfF]. Make sure the yellow record light is off. Unplug 5 minutes. Plug back in.
RESET - May take 24 hours to get your Program Guide back.
Press the red reset button under the HD DVR+'s front right access panel.
REFORMAT - & You will lose all recordings and settings!
If your HD DVR+ is not responding: First press the red reset button under the front right access panel.
As it reboots, press and hold the <J Left Arrow and the Record button at the same time on the front panel.
When the Record Light changes to red, let go of the buttons.


http://www.dbstalk.com/showthread.php?t=74426
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WORKAROUNDS!
Workarounds are exactly that: workarounds. In no way do workaround substitute for missing features.

» Wrong Info Bug “...you can set an option for program type: First Run, Repeats or Both.” p. 47.
Wrong Info Bug - The First Run/Repeat Information is sometimes wrong. A First Run may be listed as a Repeat!
Workaround - Due to the Wrong Info Bug, it is best to record Both and delete Repeats manually

» Channels | Get Bug "display only the channels that are in your current subscription package.” p. 37.

CIR Bug - Channels | Receive is broken causing errors with the Search function and Autorecord. All receivers get
the same program info via Channel 100 back channel. Only DirecTV non-TiVo receivers have this bug.

Workaround - Custom Channels Lists will help with the Guide but Search will still suggest channel you don’t get

» Search Bug "Search offers some easy ways to spot just what you want to watch." p. 31.
CIR Bug - The HD DVR+ filters out some channels you don't receive (other locals) but not others.
Workaround - Search is broken. Be careful to make sure you only record on channels you actually get!

» Prioritizer Bug
Problem - The HD DVR+ cannot edit or delete a Series Link unless there are upcoming recordings scheduled
Workaround - Press [-] DASH twice to delete the Series Link, set up a new Series Link if needed.

» Autorecord Bugs
CIR Bug - Autorecords channel you don’t get due to the Search & Channels | Get errors - can lockup HD DVR+.
Autorecord Bug - Cannot Autorecord after a Search by Title as described in the manual on pp. 20 & 31
Workaround - Autorecord is broken. Use Series Links instead of Autorecord.

» Dual Buffers (Thank you to mtnagel at dbstalk.com)
Problems - The HD DVR+ has two tuners requires a trick to watch and pause two shows at one time.
Workaround — Go to the first program and press RECORD. Go to the second program and press RECORD.
Press & the 1* recording. Press[i]. Press & the 2" recording. Press [ii] PAUSE.
Repeat these steps below to go back and forth between the programs:
Press [i] PAUSE - [BAcK]. Highlight the other show & click Play.
Press then [-] DASH twice to delete each entry when you are done.

> MyPlaylist Sort Fix
[MENU] = Search—>Keyword-->"IAMANEDGECUTTER"-> Continue—>
On the front panel press and hold down MENU & INFO at the same time for about 2 seconds.
A secret menu will let you repair the Guide button, turn off Animations, and change MyPlaylist sort default!

» List Button

List Button Bug - The LIST button does not return you to where you left off in My Playlist.
Workaround - Pressing one or more times will work much of the time.

> Native Mode Bugs
Problems - Slow channel changes, sometimes the screen flashing and jumping, sometimes followed by a lockup.
Workaround - Turn Native Mode Off: Press [ MENU], click Help & Settings > Setup > Display > Native Off

LINKS: TiVo to HD DVR+ Survival Guide Installation Tips HD DVR+ Networking Tips
HD DVR+ Owners Manual My TV Planner

This is a compilation of tips from DBStalk.com and is offered without guaranty or warranty.
Use these Unofficial tips at your own risk. Thank you to all who have shared ideas. - Craig 10/07.
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