Only sound - No picture on 622 (1 Viewer)

Register Today to see less ads! It's Free!

zzandrewst

SatelliteGuys Pro
Feb 2, 2008
155
0
South Carolina
I have a VIP 622 and a 612 and I'm having problems with my 622. I first noticed it last night, the receiver just went into the acquiring satellite signal screen and then started downloading the guide. I let it go through the process, but then it started downloading it again after it was finished. I unplugged the receiver and plugged it back in and it seemed to work a little bit better. Well, tonight I notice that on several channels (at least 5 probably many more) there is not picture, only sound. The menus and guide pops up fine, but just no tv picture, other channels work fine. I thought that there may be a possibility that my satellite is not aligned anymore, so I went to look at my 612 and it is showing the channels fine. Does anyone know if this is some kind of major bug, or is my 622 on the fritz? Thanks in advance!
 
Register Today to see less ads! It's Free!

whatchel1

SatelliteGuys Master
Sep 30, 2006
9,099
48
Great High Plains
HDMI

I have a VIP 622 and a 612 and I'm having problems with my 622. I first noticed it last night, the receiver just went into the acquiring satellite signal screen and then started downloading the guide. I let it go through the process, but then it started downloading it again after it was finished. I unplugged the receiver and plugged it back in and it seemed to work a little bit better. Well, tonight I notice that on several channels (at least 5 probably many more) there is not picture, only sound. The menus and guide pops up fine, but just no tv picture, other channels work fine. I thought that there may be a possibility that my satellite is not aligned anymore, so I went to look at my 612 and it is showing the channels fine. Does anyone know if this is some kind of major bug, or is my 622 on the fritz? Thanks in advance!

Are you using the HDMI output? If you are see if same thing is going on w/ the component video out. I have a feeling that the HDMI has gone bad & you will need to get a replacement.
 

Jimmerinwi

SatelliteGuys Pro
Nov 29, 2008
795
1
Midwest
622's are junk! See constant problems with them, a very unstable receiver in my opinion. I would call Dish, have them set up a service call, get a tech out and chances are when the tech replaces it, it is going to be a 722 or 722K, not too many techs carry 622's anymore. If you have Dish send you another receiver, it WILL be another 622 for sure. Does it suck that you'll have to pay $15 for a tech visit, yes it does, but they are going to charge you for shipping anyway, I think $15 as well, so your better off with a tech visit to maybe get a 722 or a "K". Worst thing is you lose your recordings, unless you transfer them to EHD.
 

zzandrewst

SatelliteGuys Pro
Feb 2, 2008
155
0
South Carolina
622's are junk! See constant problems with them, a very unstable receiver in my opinion. I would call Dish, have them set up a service call, get a tech out and chances are when the tech replaces it, it is going to be a 722 or 722K, not too many techs carry 622's anymore. If you have Dish send you another receiver, it WILL be another 622 for sure. Does it suck that you'll have to pay $15 for a tech visit, yes it does, but they are going to charge you for shipping anyway, I think $15 as well, so your better off with a tech visit to maybe get a 722 or a "K". Worst thing is you lose your recordings, unless you transfer them to EHD.

I won't get charged to upgrade to a 722?
 

KAB

SatelliteGuys Master
Pub Member / Supporter
Lifetime Supporter
Sep 20, 2005
20,603
3,941
Fishers, IN
I disagree with the "622's are junk" When first out, they had HDMI problems, but were rectified. I had one for three years without problem before I upgraded to a 722K. In less than a year from receiving the 722K and a 722, I've had to replace both of them. Yes, you would probably have to pay for an upgrade.
 

fredp

SatelliteGuys Pro
Apr 10, 2008
623
112
Williston, Vermont
I disagree with the "622's are junk" When first out, they had HDMI problems, but were rectified. I had one for three years without problem before I upgraded to a 722K. In less than a year from receiving the 722K and a 722, I've had to replace both of them. Yes, you would probably have to pay for an upgrade.
Your right about the 622's KAB. Pay for an upgrade is probably true. Whats not true is that if the OP 622 is determinded to be bad and he has DHPP or whatever it is called now the charge will be zip for shipping out a replacement. Went through this in April.
 

KAB

SatelliteGuys Master
Pub Member / Supporter
Lifetime Supporter
Sep 20, 2005
20,603
3,941
Fishers, IN
Your right about the 622's KAB. Pay for an upgrade is probably true. Whats not true is that if the OP 622 is determinded to be bad and he has DHPP or whatever it is called now the charge will be zip for shipping out a replacement. Went through this in April.
OK. Never said he would have to pay (well, $15.00 shipping) for a replacement. New policy since June 3.
 

Paradox-SJ

SatelliteGuys Pro
Nov 20, 2003
1,636
2
San Jose, California
I disagree with the "622's are junk" When first out, they had HDMI problems, but were rectified. I had one for three years without problem before I upgraded to a 722K. In less than a year from receiving the 722K and a 722, I've had to replace both of them. Yes, you would probably have to pay for an upgrade.

+1 on this...I had one replaced becos of the HDMI issue and since then its been rock sold ever since....
 

fredp

SatelliteGuys Pro
Apr 10, 2008
623
112
Williston, Vermont
OK. Never said he would have to pay (well, $15.00 shipping) for a replacement. New policy since June 3.
Wasn't clear. I was responding to the poster who said there would be a $15. charge for shipping a replacement. Shouldn't be... If the changes on 6/3 says you pay shipping on top of DHPP for a replacement then that would suck.
 

zzandrewst

SatelliteGuys Pro
Feb 2, 2008
155
0
South Carolina
I disagree with the "622's are junk" When first out, they had HDMI problems, but were rectified. I had one for three years without problem before I upgraded to a 722K. In less than a year from receiving the 722K and a 722, I've had to replace both of them. Yes, you would probably have to pay for an upgrade.

This is the first problem that I've had with my 622, so I don't believe that they are "junk" I noticed last night that my 612 was having problems finding all of my hd locals. This leads me to believe that maybe I've got a problem with my dish. I have noticed that there is a tree that could be in the way of the signal. Could this be a cause of the previous problems I've been describing?
 

whatchel1

SatelliteGuys Master
Sep 30, 2006
9,099
48
Great High Plains
Maybe

This is the first problem that I've had with my 622, so I don't believe that they are "junk" I noticed last night that my 612 was having problems finding all of my hd locals. This leads me to believe that maybe I've got a problem with my dish. I have noticed that there is a tree that could be in the way of the signal. Could this be a cause of the previous problems I've been describing?

I think you may have found the problem. What are you signal levels? Do they go up and down with the wind (that could be 1 of 2 things 1 badly peaked dish or 2 the tree blowing into the way). Only problem I ever had w/my 622 was when the HDMI connector broke. When I got the new HDTV and I contacted ceo dept & was allowed to upgrade to a 722k for only the price of the OTA module, 24 mnth commitment, & shipping. Many 622's had int power connectors go bad.
 

cditty

SatelliteGuys Pro
Feb 22, 2006
1,290
33
Northeast Louisiana
This happens on my 722K, sometimes on the TV hooked up via Component. I have to reset the receiver to fix it. The HDMI is still showing picture when it happens.
 
Register Today to see less ads! It's Free!

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top