Cannot access Prime Video or Netflix from Joey 3

  • WELCOME TO THE NEW SERVER!

    If you are seeing this you are on our new server WELCOME HOME!

    While the new server is online Scott is still working on the backend including the cachine. But the site is usable while the work is being completes!

    Thank you for your patience and again WELCOME HOME!

    CLICK THE X IN THE TOP RIGHT CORNER OF THE BOX TO DISMISS THIS MESSAGE

BarnRat

SatelliteGuys Pro
Original poster
Aug 30, 2021
610
1,250
SW USA
On my coax-connected Joey 3 (to a Hopper 3), when I go to channel 301 (Prime Video) the Prime Video logo shows on the screen for about 5 seconds then the Joey jumps back to whatever channel I was watching before going to channel 301. Basically nothing happens. When I go to the Hopper 3 it works fine ????

ETA: Could this have something to do with my older Sharp TV maybe not supporting DD+?
ETA: The same thing happens when I try to go to Netflix (channel 302).
 
More info -
Did these channels both work before, and now they don't on the Joey?
Is this a new set-up?
Have you tried a soft reset of the Joey?
Can you try the Joey on a different TV to rule out or rule in the TV is the problem?
 
More info -
Did these channels both work before, and now they don't on the Joey?
Is this a new set-up?
Have you tried a soft reset of the Joey?
This is the first time I've tried to use these apps. This is a new install (as of Jan 4th). The Joey has been reset several times since then. Just a few days ago was the last time.
 
  • Like
Reactions: charlesrshell
BTW, this is not a big deal. My Joey 3 TV is also connected as an alternate console to my Windows PC (a different input) and this is how I normally watch Amazon Prime or Netflix. I just thought I would try to access via the Dish interface.
 
Last edited:
  • Like
Reactions: Tampa8
That just happened on my Hopper about an hour ago. I started an Amazon Prime movie, then all of a sudden, it went black and the previous channel (sat) came on. I reselected Prime and restarted the movie and all was fine after that. Humm.
 
  • Like
Reactions: BarnRat
That just happened on my Hopper about an hour ago. I started an Amazon Prime movie, then all of a sudden, it went black and the previous channel (sat) came on. I reselected Prime and restarted the movie and all was fine after that. Humm.
That's similar to what I see. When I select Channel 301 the Prime Video logo appears, then a few seconds later the screen goes black, then it jumps back to whatever I was viewing before. It also doesn't work if I go to Menu-->Apps and select Prime Video (or Netflix).
 
Last edited:
I found this on Dish.com:

Connect a Joey to Wi-Fi
  1. Press the MENU button once or the HOME button twice, depending on your remote.
  2. Select Settings.
  3. Select Internet.
  4. Select Advanced.
  5. Select Bridging.
  6. Select OK on the Attention 1229 pop-up
When I try this from the Joey 3, the Bridging entry is set to OFF and is "greyed out" -- it cannot be selected/changed.
 
Bridging is a setting you can only change on the Hopper, have you checked it?
Thank you.

I checked it. Bridging was turned on (Hopper 3). So I toggled it off/on and still no access to Prime Video or Netflix from the Joey 3.
 
Last edited:
Could it be a "bridge mode" setting in my Netgear Wifi router? But the little I just read on this says that putting a router in bridge mode will keep the router from protecting our home network. That doesn't sound like a good thing.
 
Could it be a "bridge mode" setting in my Netgear Wifi router? But the little I just read on this says that putting a router in bridge mode will keep the router from protecting our home network. That doesn't sound like a good thing.
It is the bridge mode on your MoCa connection and has nothing to do with your router.
 
I don't see how other internet functions work fine from the Joey3 -- things like streaming (VOD) and Google Assistant. How do these work but Netflix and Prime Video don't? Because of this, it would seem that the bridge function on the Hopper 3 is working just fine. In Settings/Internet/Network Details the internet connection looks healthy.
 
Last edited:
I don't see how other internet functions work fine from the Joey3 -- things like streaming (VOD) and Google Assistant. How do these work but Netflix and Prime Video don't? It would seem that the bridge function on the Hopper 3 is working just fine. In Settings/Internet/Network Details the internet connection looks healthy.
Have you tried opening Prime with the actual app instead of Ch 301?
And I don't if you're able to, but I always tell every customer to not rely on the streaming apps on the Hoppers and Joeys if you have other means to use them, like the TV itself, Roku/Firesticks, etc. because they are so glitchy
 
Have you tried opening Prime with the actual app instead of Ch 301?
And I don't if you're able to, but I always tell every customer to not rely on the streaming apps on the Hoppers and Joeys if you have other means to use them, like the TV itself, Roku/Firesticks, etc. because they are so glitchy

Thanks.

My wife's TV, which is attached to the Hopper 3, works fine. She also has Apple TV, so she has two methods to watch Netflix and Prime Video -- and other streaming services.

My TV, which is attached to the Joey 3, is also an alternate console to my Windows PC, which is how I've always watched Netflix and Prime Video -- I guess I will continue to watch in that manner.
 
Last edited: