DISH Anywhere not working again! Go figure


SatelliteGuys Pro
Original poster
Oct 15, 2006
Not even going to waste my time trying to get a live person on a phone call. It’s been two weeks since the last time we used this at our beach house. Came back today and tried to fire it up and I immediately got a screen telling me I needed to log in. Jumped thru the hoops to get that done and now I keep getting a Login Error code. Most recent one was 0561-179236. Message says “Oops, something went wrong. Please try again later”. Well, I have tried again later and continuously get the same error message with the last six numbers being the only thing that changes. I’m using a Firestik and cleared the cache. When that didn’t work I cleared the cache again and the data. When that didn’t help I deleted the DISH App and reinstalled it. Still not working. I’m about over DISH. Any and app help appreciated. Thanks
Mine works fine on iPhone. Dish anywhere isn't really much anyone can do to troubleshoot besides making sure everything is connected to internet. So you'd be wasting your time calling in anyways. But with it being an app available on multiple platforms it's not always the vevelooers fault. It could be an issue with your firestick. Does it work on other devices such as your phone?

If you need tv at your beach house that badly then I'd definitely recommend a more reliable method as dish anywhere is far from a reliable tv source.
  • Like
Reactions: charlesrshell
It’s been stable since my original complaint. There might have been an update to the tv, firestik or the app that caused the initial problem. Whatever it was is gone.
  • Like
Reactions: charlesrshell
It never works properly at my house. We use a firestick and it plays for few minutes then rebuffs all the time. We have many other apps and ALL work fine but Dish. We call it the Dish No-where app because it never works smoothly. I know couple other people that say they have same problem.