On our third DVR receiver ... (1 Viewer)

xrae

Thread Starter
Member
Mar 17, 2006
14
0
East Tenn.
Hello all -- I am seeking help with our malfunctioning Dish DVR.

This is our third receiver from Dish. We have had two others replaced due to malfunctions with the DVR (possible hard drive related -- nobody at Dish was ever able to say for sure). I am hoping that perhaps someone here can help diagnose our problem and point us in the right direction for some real help this time.

I've browsed through the forum, but since I don't know which model receiver we have, it's hard to search for the messages that pertain to our hardware. Our DVR will record about 120 hours (or so it says), and we have only one outlet. System is hooked to one tv with single tuner.

The receiver turned itself off last night while I was switching channels -- I think I had the guide up on screen at the time. I didn't have the time to troubleshoot last night and so I powered down the system and left it until today. Didn't turn the system on until late this evening. Switched channels fine a couple of times. Then was looking through the onscreen guide, was able to set up some recordings (free HBO and Cinemax this weekend, btw), but then when I tried to change channels via the guide, the system powered down and the tv screen went blank. Then the power light on the receiver would slowly blink on and off every few seconds.

Unplugged the unit for about three minutes, plugged back in and the system went through signal acquisition. The receiver returned the channel I was watching at the time it powered down. Activated the guide again and tried to change channels, but again the system powered down and returned to the slow-power-light-blink state. Again went through the routine of unplugging the unit and letting it sit before plugging it back in and powering up. This time I attempted to change channels using the UP/DOWN buttons and was successful at first. But after a couple channels, the screen again went blank. At some point I got the message on-screen that I did not have permission to view those channels (but they were "normal" channels that we always have access to).

The unit refused to reboot by holding down the power switch for a few seconds. Had to unplug again and let the unit sit. Finally gave up for the evening.

We have had our two previous DVR units replaced due to similar malfunctions. Tech support on previous issues has been nearly impossible to work with due to their ignorance, a fact I'm sure many of you are aware of. I'm pretty sure our problems aren't due to heat around the device. It has ample air circulation and the unit does not feel hot to the touch.

Any help or suggestions?

- Rae
 

Kaydigi

SatelliteGuys Pro
Jan 1, 2004
487
0
Please look at the front of your receiver and look for numbers like 522, 625, 721 etc..

Or the next time you are able to power on your receiver look for a "system info" button on the front of the receiver and press it. You should be able to find the model number that way.
 

xrae

Thread Starter
Member
Mar 17, 2006
14
0
East Tenn.
Thank you, kaydigi. I never knew about the Sys Info button on the front! It appears our receiver is a DP510. There are no identifying numbers on the front (or sides or under or in the manual ... can't get to the back.)

ETA: DVR seems to be working properly this morning. The receiver turned itself back on last night.
 
Last edited:

Users who are viewing this thread

Top