Painless 622 purchase/install

  • Thread starter rixhd
  • Start date
  • Replies 0
  • Views 1K
R

rixhd

Thread Starter
SatelliteGuys Family
Nov 2, 2005
74
0
Port Orchard, Wa
I ordered my leased 622 May 25. I called the special number but after a 5 min hold was transferred to an Advanced Tech. Purchase was easy but she insisted I couldn't activate it myself and her supervisor confirmed that if I did, I would have to cancel the install, send the box back etc. My install date was for May 27.

I received the empty box in a few days and the 622 May 2 which really surprised me because of all the backlog discussion. It is a version D. I couldn't see waiting for 3 weeks so on may 6 I hooked it up using the hdmi/dvi adaptor from monoprice with my old DVI cable. I already had the Dish 1000 (with a Dish 500 for 129), separators and cabling installed for my owned 921. I did a check switch and a software download but eventhough the checkswitch was good it took 3 attempts before the download was successful. A word of advice: if the software download screen doesn't start showing progress in the bar at the bottom after a few minutes, boot out of it and try again. Don't wait around like I did dutifully following the instructions on the screen. If it doesn't start right away, something's wrong. Try again. I wasted an hour and a half staring at the screen (well actually I played Tomb Raider so all was not lost).

Anyway, after the software loaded, the activation screen popped up. Now I figured I was in for CSR roulette. I used the regular Dish number and selected the number for "Activating an STB." First try, I got a guy who not only knew what he was doing but didn't question me about activation. I even asked him if it was going to cause any problems. "No sir, no problem at all." He did a computer override, took my info and was just about as excited as I was about the 622 (It was his first 622 activation). He didn't cancel the installation but "closed" it instead so the scheduled installer would still get paid and I would still get the 90 day installation warranty. I aked him about that and he said I would still be intitled to have the installer come out if I had any problems in the first 90 days. Perfect!

It couldn't have gone better and the 622 is working just great so far. Today I reprogrammed my MX500 and MX700 universal remotes to work with the 622. I did notice that the remotes that came with the 622 also controlled my 721 so I had to change the remote address to 2 before I could "learn" the new 622 codes to my MX remotes. It also appears that the 921 discreet on/off codes work with the 622. I didn't change them in my MX remotes from the old 921 and they control the 622 even though I changed the address from 1 to 2. I must have changed the 921 to address 2 also a long time ago and forgot about it.

So far I had one recorded program that froze the box on playback at a point of lost signal. I was recording another program at the same time. I waited until the other program was done recording, did a front panel reboot and everything is back to normal. I replayed the program that hung the box but this time "30 sec" skipped over the pixelated area and it played flawlessly to the end. I didn't even lose the other program that was recording during the freeze.

Other than that, the box seems very stable and well thought out compared to my 921. I'm setting up Dish pass programs for the week and will report any problems. Call me a happy camper so far. :up
 
Last edited:

Similar threads

M
Replies
19
Views
1K
Miner
M
M
Replies
51
Views
2K
HipKat
HipKat
casarodante
Replies
1
Views
640
TheKrell
TheKrell
T
Replies
30
Views
3K
Howard Simmons
Howard Simmons

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top