“select” button not working.

lzboy6

lzboy6

Thread Starter
Well-Known SatelliteGuys Member
Pub Member / Supporter
May 17, 2014
28
12
California
The “select” button on my 40.0 UHF 2G remote quit working. Otherwise remote is fine. Help would be appreciated. Thank you.
Bob
 
Tampa8

Tampa8

Supporting Founder - I'll stand up and say so
Pub Member / Supporter
Lifetime Supporter
Sep 8, 2003
18,111
7,711
Tampa/Eastern Ct
Yep probably get a new one. It's possible to fix, does not always work but often does but is it worth it? (You take the remote apart, clean the rubber panels that interface the buttons to the actual electronics.)
 
Jim5506

Jim5506

SatelliteGuys Master
Pub Member / Supporter
Lifetime Supporter
Oct 19, 2004
7,753
2,678
Lubbock, Texas
pop it open and clean the contacts on the bottom of the rubber platen and the contacts on the top of the board with alcohol - what have you got to lose?
 
pattykay

pattykay

formerly crodrules
Pub Member / Supporter
Jun 14, 2014
8,243
7,140
North Central Ohio
The rest of the buttons that still work. What button receives the most use? SELECT.
For me, it is definitely the Select button. I play a lot of games in Hopper Arcade. I have already ruined the Select buttons on two 54.0 remotes. The buttons still work, but they have big gashes in the middle, from my thumb nail digging in.
 
  • Like
Reactions: charlesrshell

Similar threads

JonUrban
Replies
5
Views
4K
JonUrban
JonUrban
B
Replies
46
Views
8K
lucky86
lucky86
tomeckle
Replies
3
Views
1K
Ronald_Jeremy
Ronald_Jeremy

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top