Anyone else having problems paying their bill online?

120inna55

Supporting Founder
Supporting Founder
Sep 14, 2003
1,454
31
Athens, Texas, United States
I don't use auto-pay. I just manually pay via electronic funds transfer. Since Friday, I've been unable to do so. I can log on without difficulty. I can even get to the "pay bill" page and enter my account and routing numbers. However, after clicking "pay bill" as a final confirmation, I receive the message, "Unable to log on to system due to technical difficulties. Please try again."

Since the problem is persistent and my bill is due October 11, I went ahead and chatted with a CSR and gave him the numbers. He didn't have an explanation as to why this was happening, but he says my account will be credited accordingly. Of course, I'll keep an eye on it to ensure that is the case. He also gave me a confirmation number, so I'm sure it'll be fine.

I was just wondering if this was just me, or if any of you are having the same problem?
 

Rick Ruth

Well-Known SatelliteGuys Member
Jan 22, 2009
25
0
Shippensburg, PA
I do use auto-pay which has always worked flawlessly. However, since last Thurs. or Fri., sometimes when I login to my online account it shows that I am not enrolled. The first couple of times this happened, I re-enrolled in the auto-pay program. The third time I ignored it thinking I would call to see what was going on, but before I called I happened to login again and it showed that I was enrolled. Since then sometimes when I login it shows that I am not enrolled, other times it shows that I am enrolled. Clearly, there's a problem with the online account system!
 

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top