I activated Playboy Channel, but it doesn't show up on channel listing. HELP (1 Viewer)

sflocco

Thread Starter
Well-Known SatelliteGuys Member
Dec 22, 2005
31
0
I activated Playboy Channel, but it doesn't show up on channel listing. HELP. How do you add it on? Will there have to be yet another program upgrade to be able access it?
 

Scott Greczkowski

Welcome HOME to SatelliteGuys!
Staff member
HERE TO HELP YOU!
Sep 7, 2003
99,165
16,954
Newington, CT
Its on channel 198.

You must have the radio on when you do the activation.

It took like 2 minutes for mine to be done.

This morning I listened to the morning show for a bit, and to me the channel sounded like Maxim Radio with more sex talk.
 

JRadio

New Member
Apr 10, 2006
2
0
Re: I activated Playboy Channel, but it doesn't show up on channel listing. HELP

Unfortunately this response is not very helpful. :confused:

What if you've requested numerous times on the website for them to re-activate your account over the course of several days and you waited for hours after each request?

Can someone please post a response that details the sequence of a successful addition of channel 198.
 

awillc

Well-Known SatelliteGuys Member
Oct 25, 2004
27
0
Once it's ACTIVATED, the signal gets REFRESHED which updates your lineup. Sounds like you are "ACTIVATED" but are losing out on the REFRESH. You can do the REFRESH through XM Online yourself under "Manage Your Account". I have had the same experience as Scott - less than 5 minutes - even went so far at to have the car and XM on before I did the refresh.
 

JRadio

New Member
Apr 10, 2006
2
0
TimeTrax for Sirius is still not loading channel 198

awillc said:
Once it's ACTIVATED, the signal gets REFRESHED which updates your lineup. Sounds like you are "ACTIVATED" but are losing out on the REFRESH. You can do the REFRESH through XM Online yourself under "Manage Your Account". I have had the same experience as Scott - less than 5 minutes - even went so far at to have the car and XM on before I did the refresh.

Hmmm.... It's now a month later and still the channel hasn't shown up. I've tried every combination of refresh/wait/reload/restart that I can think of. I opened a ticket with TimeTrax and they were no help, either. And I do know how to activate and refresh... my car tuner added the channel without a problem with a simple web request. :music:

I am a long time user of TimeTrax, and have used it since the beta days of the XM version, so I do know what I'm doing. :cool:

I have suspected this was a TimeTrax problem (either HW or SW), but they are predictably evasive. Does anyone have any insight? Has anybody gotten this to work? Anybody have the same problem I do? :confused:
 

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top