Major 522 Issues...Help needed!!!

G

gaoxiang

Thread Starter
Member
Apr 4, 2005
6
0
522 Audio/Video Problems...Help needed!

I just installed a new system with a Dish 522 two weeks ago. The first receiver had some bad issues, so I had Dish send me a new one via mail. Well, I have the new one installed and it seems even worse (I assumed the first one was just a remanufactured dud!)! I will mention that I previously used a 501 receiver for several years at my old house and it worked like a charm. I will list the 522 problems below that I have not seen addressed in this forum (since I seem to have all the bugs already mentioned here!) and hope that someone can provide insight and advise on what I should do next. I am wondering if I should have Dish send me my third 522, or if a technician needs to come and check my installation. Also, does anyone else have the clicking/popping audio problem?

ISSUES:
1) When changing channels, skipping forward or backward, the audio makes a loud and very annoying "popping" sound. The screen flickers as well. This occurs on both the old and new receiver.
2) Playback of recorded DVR events sometimes has bouts of major picture distortion, or major pixelization. This usually lasts for one or two seconds and is often accompanied by loss of audio.
3) When skipping back, the picture completely freezes up. Pressing play or pause buttons does not fix the problem, as it stays locked up. The only way to get out of the freeze is to first hit rewind and then resume play.
4) The audio mutes randomly for one to four seconds, mainly when watching recorded DVR events.
5) When pressing pause, the audio continues playing for one or two seconds after the video has stopped. When resuming play, the video goes without sound for the same amount of time. This occurred on both the old and new receiver.

What should I do?!?!?!?
 
G

gaoxiang

Thread Starter
Member
Apr 4, 2005
6
0
Does anyone have similar problems with there 522?

Just wondering if my problems are unique....
 
B

Bizzach

SatelliteGuys Pro
Mar 9, 2004
209
0
gaoxiang said:
What should I do?!?!?!?
...Learn to live with it! :p

All those issues are common ones, BUT they shouldn't be happening very often. Mine is still watchable (who cares if the audio plays for a second after pushing pause!??), so I don't really worry about it. Before they fixed the horrible audio dropouts, yeah, I was pissed.
You can call Dish and request another 522, but chances are, it'll be just the same...
 
G

gaoxiang

Thread Starter
Member
Apr 4, 2005
6
0
Does your audio pop and screen flicker when you change channels or use dvr features such as skip back, pause, etc?

Are you saying they have already fixed the audio dropouts? Mine is brand new, but is still having this issue.

Thanks!
 
K

kbohip

SatelliteGuys Pro
Feb 9, 2005
293
0
Colorado Springs
Mine has already had almost all of the same problems and I've only had it for a few weeks. They haven't fixed the audio problem, or the pixelating video problem for that matter. Mine has audio dropouts CONSTANTLY! The 522 is a very buggy machine. I had a 510 before this and it was almost perfect. If the 522 was at all like the 510 I wouldn't be leaving Dish when my contract is up. I don't know what they were thinking with the 522.

After seeing my parent's new Directivo system, I can't wait until my Dish contract is up.
 
Jahntassa

Jahntassa

SatelliteGuys Family
Jun 4, 2004
99
0
Atlanta, GA
The random mutes are my only problem. I'm using optical off the main box, and coax off the second tuner output in single mode. Usually it's a little 'drop out' and there's a video glitch at the end of the audio dropout. It's not so bad recently. No complete hangs or anything though. I got my 522 last April/May
 
C

CopyChief

SatelliteGuys Guru
Feb 21, 2005
145
2
I have occasional pixelation (not a huge deal, I've seen this on digital cable and even Tivo systems, os I figured it comes with the territory). I have occasional audio dropouts; thankfully these are not ALWAYS followed by things being dramatically out-of-sync as they once were. I still notice audio and video being out-of-sync on occasion, on both live and recorded programs. But (knock on wood) I have never seen problems like you're describing. Do the audio glitches (in point #1) happen on all audio outputs -- coax, RCA and digital?
 

Similar threads

P
Replies
6
Views
1K
psycaz
P
C
Replies
2
Views
1K
Mark_AR
Mark_AR
C
Replies
2
Views
1K
Mark_AR
Mark_AR
S
Replies
9
Views
2K
Shadowtester
Shadowtester
B
Replies
6
Views
1K
KAB

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top