Pocketdish Help

Pro Satellite

New Member
Jan 24, 2006
4
0
I need some expert advise. I have a 625 that needs L2.92 software upgrade.
Tech Support tells me that my L2.91 can't receive a newer upgrade because
it thinks L2.91 IS the latest. How can I get option 4 (Multimedia).
 

n0qcu

Supporting Founder
Supporting Founder
Sep 7, 2003
4,900
1,483
Earth
The only thing you can do is wait. There is no way to force a download before its time.
L2.92 has been out for three weeks now so either it will be released to everyone fairly soon or they found a major bug and are fixing it resulting in an unknown amount of delay.
 

Pro Satellite

New Member
Jan 24, 2006
4
0
I've installed several 625's in my area all receivers excepted the L2.92 upon
activation. Tech's told me mine would not accept the new L2.92 because it
thinks the L2.91 is the newest version.
 

n0qcu

Supporting Founder
Supporting Founder
Sep 7, 2003
4,900
1,483
Earth
"NEW" out of box receivers always download the newest version. All others must wait their turn.
 

Kaydigi

SatelliteGuys Pro
Jan 1, 2004
487
0
n0qcu said:
"NEW" out of box receivers always download the newest version. All others must wait their turn.



Yeah my RMA 522 received 2.92 upon activation while my 625 has not.
 

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top