Problems with WD 2T MyBook External EHD - is it fixable? (1 Viewer)

docdaddy

Thread Starter
SatelliteGuys Pro
Sep 2, 2016
459
274
Birmingham, AL
My Western Digital 2 TB USB 3.0 My Book Desktop External Hard Drive apparently spins down as a powersaving thing, when not in active use, so every time I switch to it then try to play a program I get the "Drive Spinning Up" message then a blank screen. And it just stays in blank screen. I have to go back to live TV and change channels and then come back for it to work. This is a PIA and my wife just doesn't use it for that reason. I also routinely

I can't find a way to turn off the power saving mode, so I'm thinking I may need to find another drive where I can turn off this kind of behavior - any suggestions? (Unless someone has a link to how to fix my drive.) This will be a pain, because I have more stored on my EHD than I have space on my internal drive. :(
 

n0qcu

Supporting Founder
Supporting Founder
Sep 7, 2003
4,868
1,442
Earth
Go to the western digital web site and search for the WD Drive Utilities and download and install on your PC. You will then be able to turn off the sleep mode.
 
  • Like
Reactions: charlesrshell

patmurphey

SatelliteGuys Pro
Dec 29, 2006
1,277
415
New Jersey
It's the new normal. You can wait a minute or so to play a recording so that the Hopper3 can initialize the drive, or just quickly go through the steps you mentioned. Don't worry about it, there's nothing wrong with the drive.
 

docdaddy

Thread Starter
SatelliteGuys Pro
Sep 2, 2016
459
274
Birmingham, AL
It's the new normal. You can wait a minute or so to play a recording so that the Hopper3 can initialize the drive, or just quickly go through the steps you mentioned. Don't worry about it, there's nothing wrong with the drive.

I'll try again, but I have tried waiting and it seems it never comes on.
 

docdaddy

Thread Starter
SatelliteGuys Pro
Sep 2, 2016
459
274
Birmingham, AL
Go to the western digital web site and search for the WD Drive Utilities and download and install on your PC. You will then be able to turn off the sleep mode.

Do you happen to know if these will still work on the drive while it is formatted by the Hopper 3?
 

docdaddy

Thread Starter
SatelliteGuys Pro
Sep 2, 2016
459
274
Birmingham, AL
I guess what bugs me about this (and I tried to wait for the H3 to determine it had "spun up" - it never did start the program) - I've never had this issue with EHD's with past Dish receivers, nor with the Genie. It seems like it is at root a H3 issue.
 

DishSubLA

SatelliteGuys Master
Apr 9, 2006
5,217
1,079
I've had the same thing happen to me 4 times in the past 3 weeks on my HWS and it was a pain (glad I'm not the only one), but usually on my HWS when I select the EHD, the tumbnails in the DVR list have no images for about 5 seconds while the drive spins up, and then the thumbnails are populated with images and I am good to go. So, this problem has happended on at least my HWS.
 

docdaddy

Thread Starter
SatelliteGuys Pro
Sep 2, 2016
459
274
Birmingham, AL
I've had the same thing happen to me 4 times in the past 3 weeks on my HWS and it was a pain (glad I'm not the only one), but usually on my HWS when I select the EHD, the tumbnails in the DVR list have no images for about 5 seconds while the drive spins up, and then the thumbnails are populated with images and I am good to go. So, this problem has happended on at least my HWS.

I wait until the images spin up but I still have the problem. Very frustrating,
 

docdaddy

Thread Starter
SatelliteGuys Pro
Sep 2, 2016
459
274
Birmingham, AL
Depending on how full your drive is, it takes longer than jus populating the icons.

You're right, but I've switched to the EHD and waited for a couple of minutes and still had the problem.

I just used the WD utilities to turn off sleep mode (and the flashing bright white LED) - I'll wait for a couple of hours and then see if that has any effect.
 

docdaddy

Thread Starter
SatelliteGuys Pro
Sep 2, 2016
459
274
Birmingham, AL
I did use the WD utilities and turned off Sleep Mode and that solved the issue of having to jump through hoops to play a program from the EHD - now I just choose the EHD source, choose a program, and it plays just as if it came from the internal HDD.

I still have issues transferring files to the EHD unless I only move a program at a time (or not much more than that.)
 

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top