Watch out for bad EA hybrid lnbs (1 Viewer)

dishstaller

Thread Starter
SatelliteGuys Family
Lifetime Supporter
Oct 1, 2003
53
10
I've already had two EA hybrid lnbs go bad and both had exactly the same symptoms so I figured it was worth mentioning. The symptom is that the signal will just drop for no reason and then come back....the length of time of the outage will get longer and longer. We've been having torrential rains the past two months so at first I was just thinking that was the issue but we had a few days where it didn't cloud up until later in the day but customers were still having signal drops in the morning when the sky was clear blue. Replaced lnb, problem went away.
 

boba

SatelliteGuys Master
Dec 12, 2003
11,350
1,033
Dorchester, TX.
Sounds a lot like problems DISH had about 10 years ago. A run of LNBs had temperature sensitive components they failed in the sunshine and cooled off at night, worked at night and early morning then failed in the heat of the day.
 
  • Like
Reactions: stardust3

ilfoman

SatelliteGuys Family
Jul 18, 2011
104
0
North
Just wondering if it's possible to revert to legacy lnb's if DPP's fail. Would the old lnb's work with a 211k using one of the old SW21's? Thanks.
 

boba

SatelliteGuys Master
Dec 12, 2003
11,350
1,033
Dorchester, TX.
Just wondering if it's possible to revert to legacy lnb's if DPP's fail. Would the old lnb's work with a 211k using one of the old SW21's? Thanks.
Hybrid LNBs are not DPP. they are hybrids for use with the Hopper. Legacy LNBs could be used with SW-21 switches and Dish Pro LNBs could be used with DP-21 switches.
 

Joe891

SatelliteGuys Pro
Nov 9, 2015
427
154
Maryland
Thankfully my ea hybrid lnb has worked great only going out for strong storms so far but now I'll know to keep my eyes out for it thanks for the heads up
 

Stargazer

Supporting Founder
Supporting Founder
Sep 7, 2003
16,561
338
Western WV
I had to replace mine as well. How can you get Dish to send one to me to replace the one I had to put on there?
 

ERSanders

SatelliteGuys Pro
Mar 3, 2004
394
47
Fairport, NY
Same problem here. The tech said the LNB was running hot to the point he could feel the increased temperature. Also replaced the hub, but I think that was a belt and suspenders fix.
 

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top