811 wont power on Superbowl Sunday eve (1 Viewer)

bmwaaron

Thread Starter
SatelliteGuys Family
Supporting Founder
Nov 25, 2003
99
0
Well topic says it all, went to turn it on today and it will not power on. Left it unplugged for 5 hours and tryed again, still no power on. And the day before the Superbowl when I have people comming over to watch HDTV..... Anyone else have no power up problems?
 

Bruce

That is my dog Bender.
Supporting Founder
Nov 29, 2003
6,147
5,995
My 6000 that my step-father is using(I have the 811 he is on the never will get waiting list for his 811)will not power up(died last nite) and he is mad at me over it because he has 20 people coming over t-nite.
 

LarryH

SatelliteGuys Family
Sep 8, 2003
45
0
bmwaaron said:
Well topic says it all, went to turn it on today and it will not power on. Left it unplugged for 5 hours and tryed again, still no power on. And the day before the Superbowl when I have people comming over to watch HDTV..... Anyone else have no power up problems?
I had the same problem with my 811 yesterday. The good news is that I was able to break mine free. The bad news is that I'm not sure how I did it. I'm pretty sure that the only things I tried was holding down the power button for 15 seconds and unplugging the power a couple of times. It's still working fine today...
 

Ray S

SatelliteGuys Pro
Sep 7, 2003
256
1
Central NJ
bmwaaron said:
Well topic says it all, went to turn it on today and it will not power on. Left it unplugged for 5 hours and tryed again, still no power on. And the day before the Superbowl when I have people comming over to watch HDTV..... Anyone else have no power up problems?
It happened to me. I tried everything, called tech support. Returned it and got another one in two days. But it only happened after I moved it to the bedroom and tried turning it on. I had just gotten the 921 for the living room. When I plugged it in I noticed a light out of the audio digital output but no power light and no picture.
 

bmwaaron

Thread Starter
SatelliteGuys Family
Supporting Founder
Nov 25, 2003
99
0
Well I got it working, just hit it a few times on the side and it powered up... Prob not a step in the CSR's playbook for fixing but hey it worked.........
 

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top