922 EHD problem

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
Since receiving my new 922 in March I've had an occasional problem with the EHD. When I go into the DVR menu the my 922/ext. device tab is completely missing sometimes. It's as if the 922 is not seeing the EHD at all. If I unplug the usb cable though I get the on screen message saying that a usb device has been disconnected. This problems seems to occur at random times. Usually a soft re-boot will get it back although I did have to do a power cord pull to get it working again one time. I have tried a different usb cable and plugging the EHD power supply directly into a wall socket instead of a surge strip, neither helped. I also tried using the front usb jack with no difference. I've been living with this issue vrs. having a new receiver sent because I didn't want to trade a brand new receiver for a re-furb that might have more problems than mine does. Aside from this issue the receiver works great and I really like it.

Last week while looking at my account on Dish's website I noticed that the 922 showed EHD not activated even though it was working at the time. My 211 which I have setup with a EHD did show that it was activated on that receiver. I called tech support and the guy I spoke with in Virginia had no idea why it didn't show activated on my account. He sent a re-hit (hope that's the right term) which did not help. He then said that a ticket would be generated. I asked if that meant that someone would be calling me back. He said no that a future software update should take care of the problem??? Does it make any difference whether it shows the EHD activated or not on your account?

Any help would be appreciated.

For reference I have a WD 1tb essential 2.0 with it's own power supply.
 

garygaryj

SatelliteGuys Family
Jul 6, 2011
87
0
VA
Same here. My EHD occasionally disappears. I just wait for the overnight reboot, and it is always back the next day. I'm thinking this is not a hardware issue, but a software one, and hopefully will get fixed in the next release. In the meantime, I certainly back-up my most important programs on the EHD, and most of the time - it is there, and works great.

I do find that several channels seem to have some problem with having anything other than a generic channel icon on the EHD, rather than the custom one for a movie or program. Do you see this?
 

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
Nightly re-boot? I knew it was set to download updates at 3am but didn't know that it re-booted also. In any event the device tab on mine comes back only when it feels like it. There have been times when it disappeared for a week or so only to suddenly show up again. Other times it may stay working for 2-3 weeks only to vanish again. There's no rhyme or reason. I had thought that it might be a software problem too from past experience with other issues. I still wonder why it doesn't show enabled on my account?? Does it on yours?

I haven't noticed any channel or movie title problems. There are times when it can't seem to find a logo for a particular movie but most show something other than a generic.

I did notice though that the channel guide has started defaulting back to the My Channels list every night even though you might have a different favorites list selected. Someone reported on the "other" forum that this just started happening with a recent software update.
 

garygaryj

SatelliteGuys Family
Jul 6, 2011
87
0
VA
Interesting. One can wonder why the same software on the same firmware on the same hardware will produce different results. Modern day "miracle."

I was believing it was rebooting after the update each night, mainly because I changed the update time to early morning, and found that as I watched, it would update and reboot. (Doesn't take nearly as long as the competition's reboot, by the way.) But I put it back to 4 AM on my box. I think there must be some kind of programming to delay the reboot if something is scheduled to record in the middle of the night during that update time. Wish that we had a more detailed list of how the box is supposed to operate, or what one should expect.

Enabled? Please explain further what screen and field you are seeing that - and I will check mine.

I have only noticed the defaulting back to "My Channels" on the guide when I have logged-into the box with Dish Online. I have also realized that when I access by Dish Online or Remote Access, it leaves the lights on my 922 on, and doesn't turn the box back "off." (Yes, I realize the box is never truly and fully "off.")
 

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
Enabled? Please explain further what screen and field you are seeing that - and I will check mine.

If you log in to your account on Dish's website and click on "My Equipment" it will show (with pictures) the receivers that you have. Underneath that it says external hard drive enabled or not enabled. My 922 says not enabled, the 211 says enabled.
 

garygaryj

SatelliteGuys Family
Jul 6, 2011
87
0
VA
Thanks, Jeff.
I checked, and on mine, it says "not enabled" for my 922. I only have a single 922 - no other equipment, other than the single EHD I have connected to it.

40 min later - PS: What a coincidence. I went to my 922 tonight after writing this response, only to find my EHD was nowhere to be seen. Could it have had something to do with the fact that I had accessed the DVR via Dish Online a little earlier? (I was looking to see if "enabled" language was present... of course it wasn't, because there is no capability to view the EHD remotely (right?)

So - perfect opportunity - I set the Updates on Settings to be 12 midnight, and turned off the machine a couple minutes earlier. It did, in fact, try to download any update, and then rebooted the machine. I had kept my Panasonic TV on during this time. At the end of the reboot, it said a quick message, something like "External media connected on port 1" (not precise wording.) And sure enough - the EHD was there again after turning the unit back on.
 
Last edited:

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
I'm glad that at least one other person in the world is experiencing the same issues that I have been having with the EHD. I don't yet have mine connected to the internet so I can't comment on whether you can view the EHD remotely or not. Makes sense that if your unit is rebooting that the EHD would come back. A soft reboot brings mine back most of the time. I don't know if mine does the same thing at 3am because I'm never up at that time. I guess I could try setting mine to update at a different time just to see if it rebooted. Maybe somebody else could chime in on what generally happens at the pre-selected update time. Could be that if it rebooted I would see the EHD the next day but if the 922 didn't receive an update worth rebooting than I might not?? Just guessing here.
 

MaryB@SlingTV

SatelliteGuys Pro
Dec 29, 2010
1,251
11
Colorado
When Dish Network removed the EHD activation fee for all VIP DVR receivers, they will no longer show enabled. DISH Network no longer requires this feature to be activated on accounts with a VIP DVRs. The VIP211 family receivers will show enabled because the $40.00 fee was paid and DISH Network enabled that feature on your account. I am reporting the issue with being unable to find the EHD at various times on the VIP922 but that reboot does resolve it. We will look into this issue further.
 

sethwell

SatelliteGuys Pro
Oct 16, 2008
1,611
58
Booneville, AR
your EHD could be going into a sleep mode too. that might be why it does not show up. you may try and disable it to see if that fixes it.
 

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
When Dish Network removed the EHD activation fee for all VIP DVR receivers, they will no longer show enabled. DISH Network no longer requires this feature to be activated on accounts with a VIP DVRs. The VIP211 family receivers will show enabled because the $40.00 fee was paid and DISH Network enabled that feature on your account. I am reporting the issue with being unable to find the EHD at various times on the VIP922 but that reboot does resolve it. We will look into this issue further.
Thanks Mary, I had a feeling that it didn't make any difference whether it showed ext. device enabled or not under the 922. You can understand why folks that are having problems with their EHD might question it though. Maybe to avoid confusion they should show it enabled for everyone instead of not enabled.
 

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
your EHD could be going into a sleep mode too. that might be why it does not show up. you may try and disable it to see if that fixes it.
I have been wondering about this for a while. In all of the threads that I have read including the 1500 post EHD bug thread I haven't seen anyone post that this was happening and causing problems with a Western Digital EHD. How do I disable sleep mode?
 

sethwell

SatelliteGuys Pro
Oct 16, 2008
1,611
58
Booneville, AR
JeffN9 said:
I have been wondering about this for a while. In all of the threads that I have read including the 1500 post EHD bug thread I haven't seen anyone post that this was happening and causing problems with a Western Digital EHD. How do I disable sleep mode?
I'm not for sure about your specific drive but I'm sure you could go to WD's website and look at the docs for your drive.

Sent from my iPhone using SatelliteGuys
 

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
I do have the same model WD Essential 1tb drive connected to my computer. Last night I clicked on the drive to open it and it did have WD Smartware installed that gives several user options including sleep timer settings. There are several settings including never which means that the drive would never shut down. The default setting is 10 minutes. I wonder why if this is the problem that it only occurs at random and not all of the time??

I've read some horror stories of people accidentally re-formating(erasing) their hard drives. If I connect the drive I use for the 922 to my computer for the first time is there the possibility that could happen? My other concern is setting the drive to run 24/7. WD recommends shutting the drive down when not in use but they also say their drives are designed to run all the time??
 

MaryB@SlingTV

SatelliteGuys Pro
Dec 29, 2010
1,251
11
Colorado
I do have the same model WD Essential 1tb drive connected to my computer. Last night I clicked on the drive to open it and it did have WD Smartware installed that gives several user options including sleep timer settings. There are several settings including never which means that the drive would never shut down. The default setting is 10 minutes. I wonder why if this is the problem that it only occurs at random and not all of the time??

I've read some horror stories of people accidentally re-formating(erasing) their hard drives. If I connect the drive I use for the 922 to my computer for the first time is there the possibility that could happen? My other concern is setting the drive to run 24/7. WD recommends shutting the drive down when not in use but they also say their drives are designed to run all the time??
Hi Jeff, I will pass along your feedback regarding all DVR receivers showing activated. If you connect your EHD to your computer it will require it to reformat and all recording will be lost. You will need another EHD for your computer and they are not interchangeable. Since the sleep mode seems to be causing your issues, I would set it to "never" and just monitor the EHD. It will be getting power all the time but it will not always be working. Good Luck and keep us posted!
 

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
Hi Jeff, I will pass along your feedback regarding all DVR receivers showing activated. If you connect your EHD to your computer it will require it to reformat and all recording will be lost. You will need another EHD for your computer and they are not interchangeable. Since the sleep mode seems to be causing your issues, I would set it to "never" and just monitor the EHD. It will be getting power all the time but it will not always be working. Good Luck and keep us posted!
Mary thanks for the info.I was a little concerned that something bad might happen if I connect the drive to my computer after it was formatted to run with the 922. I really don't want to lose all of my recordings especially the last Superbowl. Who knows when the Packers will be in it and win it again.

I'm still not convinced that the sleep mode is causing my problem but I guess the only way I'm going to find out is if I buy a new EHD (without a sleep timer or disabled) and try it. Seems to me that if this was an issue that there would be hundreds of others reporting it since the basic WD Essential is the drive a lot of people have. One of my co-workers has the exact same setup(922 & WD Essential) and has never had the problem. I also never had the problem when the same drive was connected to my 622 but I understand that receivers can be different.
 

MaryB@SlingTV

SatelliteGuys Pro
Dec 29, 2010
1,251
11
Colorado
Jeff I do not recommend you getting a new Hard Drive to see if the sleep mode is causing your issue, Are you able to change the setting on the EHD? Let's change the setting and see if it resolves your issue. Please let me know! Thanks!
 

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
Jeff I do not recommend you getting a new Hard Drive to see if the sleep mode is causing your issue, Are you able to change the setting on the EHD? Let's change the setting and see if it resolves your issue. Please let me know! Thanks!
The only way that I can change the sleep timer setting (that I know of) is to connect the drive to my computer and open the smartware menu. If I do that the computer will want to re-format the drive, right? Am I missing something here??
 

MaryB@SlingTV

SatelliteGuys Pro
Dec 29, 2010
1,251
11
Colorado
I misunderstood your post. I was not aware that you were unable to change the setting with connecting to the computer. You were not missing anything, I was.
 
Last edited:

JeffN9

Thread Starter
SatelliteGuys Pro
May 5, 2007
286
110
Oregon, WI.
I mi9sunderstood your post. I was not aware that you were unable to change the setting with connecting to the computer. You were not missing anything, I was.
I guess I'm really not sure what will happen if I connect the drive to my computer. Will it start re-formatting right away and delete my recordings or will I be able to access the smartware menu and disable the sleep timer?? I really don't know and am afraid to try. Maybe one of the experts on here can chime in on this????
 

MaryB@SlingTV

SatelliteGuys Pro
Dec 29, 2010
1,251
11
Colorado
It will automatically try to reformat when connected to any other device. It cannot be switched at this point. I was hoping to make sure that it would fix your issue before having you invest in a new hard drive but that does seem possible at this point.
 

Users Who Are Viewing This Thread (Total: 1, Members: 0, Guests: 1)

Top