942 Sound problems (1 Viewer)

scorer1

Thread Starter
Member
Apr 6, 2006
13
0
I have read several posts here from people that are reporting problems in the sound skipping on their 942. I purchased mine new in January and have had problems with it since I got it. Whenever it is recording something, the voice has intermittent skips the entire time. It is VERY nerve wracking. I have been calling and complaining to Dish Network ever since I got the receiver and they tell me that it's a documented problem and they are working on a software upgrade. My question is this: Does EVERYONE that owns a 942 have this issue or are there people out there that don't? And if some don't, shouldn't Dish Network be replacing the ones that do since they don't appear able to fix it through a software upgrade? I am so frustrated! As you all know, I paid a lot of $ for this receiver to be having to settle for this issue.

Any thoughts?

Jeanne K.

Also, if you are one of the people that has NO SOUND issues with the 942, could you tell me what connections you are using?
 

scorer1

Thread Starter
Member
Apr 6, 2006
13
0
gdarwin - How do you have it connected? What wires and connections from the 942 to your tv?

Jeanne
 

gdarwin

Supporting Founder
Supporting Founder
Lifetime Supporter
Feb 9, 2005
4,297
109
Lousville, KY
I'm using the Digital Audio (toslink) to the Denon receiver. Audio on the tv is turned off. Everything goes to the receiver to drive the DD 5.1 surround sound.
 

RobertsD

SatelliteGuys Pro
Nov 22, 2005
443
0
Layton, UT
No problem's when watching any TV with my 942 and an optical cable going to my Sony Surround sound reciever.

When watching recorded stuff, there are ocassionally sound drops for like 1/2 second. It rarely happens, and doesn't really bug me. This also happens on my 625 using regular composite cables, again, only during recordings.
 
Last edited:

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top