Azbox Premium stuck on one channel

maywod

Member
Oct 2, 2007
5
0
My receiver will only show one channel on the TV. It will not respond to the remote control to allow me to go to "Home" or change channels on the satellite that it is on. I have tried to update the software but it will show the "Upgrade" options but I cannot choose option 1 to get it to do the upgrade from the usb. The "oK" button on the front of the unit is not being recognized by the receiver either. I am using software 4931. I have been using the unit since summer 2010, until now without any problems. Any suggestions?
 

AcWxRadar

SatelliteGuys Pro
Apr 26, 2006
4,575
4
40 miles NW of Omaha. Omaha?
Maywood,

Here is a possibility, not sure about it, but it is something to try. This expressly so since your remote is being ignored as well as the front panel buttons... Shut-down and unplug the receiver and open it up. Find all the connectors and ribbon cables that lead to the front panel and reseat them (meaning unplug and plug them back in). Reseat the connectors at both ends if possible (at the front panel board and at whatever other board they come and go from). Some might be soldered at one end, don't worry about those. Take a close look at each connector before you grab hold of it and note if any appeared to be not fully seated.

You might simply just have a poor connection and this excercise will correct it if that is the case.

Wouldn't hurt to reseat ALL the connectors you can elsewhere in the receiver, just to make sure they are all fine.

Good luck!

RADAR
 

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top