azbox wont recognize hard drive..other receiver does

M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
OK this is weird

Won a 40GB portable hard drive off ebay for like 10 bucks shipped. Yeah I know its small but it works.

Hooked it up to the sathawk and formatted it as FAT32...works fine

Hook it up to the azbox and it lights up when you power on the azbox but then wont show up when you select drive. There are 2 power cords on it
green one that says "power & data"
blue when that says "power only"

The green one works fine on the sathawk....wonder why the azbox wont accept the drive?

Anybody used a portable drive on the azbox? I have a WD 320GB one that works fine but that is plugged into a/c
 
AcWxRadar

AcWxRadar

SatelliteGuys Pro
Apr 26, 2006
4,575
4
40 miles NW of Omaha. Omaha?
There are 2 power cords on it
green one that says "power & data"
blue when that says "power only"

Ice,

Is this a USB HD with an option for an external power supply? I wonder if the power connection has anything to do with it. Did you try to connect the separate power connection? Als, did you do a hard reboot of the AZBox with the HD attached?

Anybody used a portable drive on the azbox? I have a WD 320GB one that works fine but that is plugged into a/c

I have used a Maxtor OneTuch USB HDD with my AZBox and it worked very good. I opened this HD case to see what was inside and found it to actually be a Seagate Barracuda 7200.11 p/n 98X156-568.

RADAR
 
B.J.

B.J.

SatelliteGuys Pro
Oct 15, 2008
2,029
1
Western Maine
I'm a little confused relative to the description of the "power cords", however I have a couple computers that have multiple USB ports, and some of them are kind of data only, and some of them can supply power to external devices. Some devices have adapters that can connect to a non-powered USB port, but share the power from a powered USB port. Perhaps this hard drive somehow has separate power for the electronics and the motor or something, and the power from a non-powered USB can run the electronics, but not the motor, but perhaps your other box has a USB with more power capacity that can somehow run both motor and electronics....? I'm really guessing here.
I have a REALLY bare bones external hard drive adapter, that is nothing more than a power plug module, and a very small circuit attached within a EIDE style hard drive plug. The whole circuit + plug is about the size of a 25 pin RS232 plug. Everything just sits on your desk, no enclosure at all, just wires and a plug. But the power module goes straight to the HD, but has a pig-tail that feeds the data connector to the HD-USB circuit board. I've long since lost the 1 page instructions, but I seem to remember that the pig-tail power connection to the circuit board was optional, depending upon whether the USB on the computer had enough power to power the electronics.
This sounds kind of similar to what you describe. I've always used it with the pigtail attached.
Come to think of it, I think I tried this hard drive adapter on the Azbox once, and it didn't work, however I think it was because the hard drive I was using was corrupted, because I later couldn't get it to work in my computer either. I'll have to try that again.
However the other suggestion I had, was to reboot the Azbox. I connected an old hard drive to mine the other day, one that I previously had attached to my Diamond, and at first the Azbox didn't recognize it. After rebooting, however, it did recognize it. I was lazy,however, and rebooted via the telnet command, which for some reason COMPLETELY rebooted it, to the extent that it came up in PAL, and I had to connect A/V lines to see the screen again. But after going through that process, it worked fine with the hard disk.
 
AcWxRadar

AcWxRadar

SatelliteGuys Pro
Apr 26, 2006
4,575
4
40 miles NW of Omaha. Omaha?
Ice and B.J.

Yes, I would be suspecting something to deal with the power connection. If this HD is similar to my Maxtor OneTouch, it may require that external power to actually drive it. The Maxtor basically contains a SATA HD, and it isn't recognized until the external power is applied.

This does leave me a little surprised that the SatHawk recognizes it, though. But, just possibly, the SatHawk's USB port supplies both +12vDC and +5vDC and the AZBox may only supply the +5vDC?

RADAR
 
putney

putney

SatelliteGuys Pro
Aug 12, 2009
854
6
St Louis, missouri
I have a 2.5" mini drive that came with a 'Y' usb cable. You are supposed to plug both ends into separate ports on computers (azbox) that have weak usb power. That being said, my Az is powering my mini drive off of one port.
 
catamount

catamount

SatelliteGuys Pro
Jun 9, 2009
627
167
maritimes
I have a seagate external notebook drive with the same cable. On my trio and most computers, I need only plug in the "power + data" cable. However, on one older P2 it required both cables to work.

Like the others said, I would reboot with harddrive attached. If it didn't work I would use the second cable (if AZbox has two usb ports)'

Lastly, I would use swissknife to reformat drive with computer. It works great and is available on Satellite AV's website. I think it is recommended under the geosat Pro 200 area. My cnx wouldn't format my drive.

Cheers, Catamount :):)
 
M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
Ice,

Is this a USB HD with an option for an external power supply? I wonder if the power connection has anything to do with it. Did you try to connect the separate power connection? Als, did you do a hard reboot of the AZBox with the HD attached?

yes its a USB HD. There are 2 USB plugs on it
one is green and is stamped "power + data". The blue end says "power only"

Its a seagate unit. I did turn off the azbox (switch on back), inserted drive, and powered back on
 
M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
This does leave me a little surprised that the SatHawk recognizes it, though. But, just possibly, the SatHawk's USB port supplies both +12vDC and +5vDC and the AZBox may only supply the +5vDC?

RADAR

the Sathawk as soon as you turn on the reciever it says "USB connected" on the screen and it records just fine with only the one cable attached
 
M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
I have a 2.5" mini drive that came with a 'Y' usb cable. You are supposed to plug both ends into separate ports on computers (azbox) that have weak usb power. That being said, my Az is powering my mini drive off of one port.

interesting....I tried both ports on the azbox and nothing.

Maybe I'll try both USB ports from the HD but that kinda defeats the purpose if I need to hog both USB ports
 
M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
I have a seagate external notebook drive with the same cable. On my trio and most computers, I need only plug in the "power + data" cable. However, on one older P2 it required both cables to work.

Like the others said, I would reboot with harddrive attached. If it didn't work I would use the second cable (if AZbox has two usb ports)'

Lastly, I would use swissknife to reformat drive with computer. It works great and is available on Satellite AV's website. I think it is recommended under the geosat Pro 200 area. My cnx wouldn't format my drive.

Cheers, Catamount :):)

The Sathawk was able to format it as FAT32 just fine. But the azbox wont recognize it.

Its a Seagate portable hard drive if that matters ;)
 
M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
yep just tried both USB ports into it and it does recognize it now. I'd have to reformat it because it shows as a NFTS now (weird...it was formatted as a FAT32)

I guess next time try all options before asking ;)
 
johnnynobody

johnnynobody

SatelliteGuys Master
Pub Member / Supporter
Aug 2, 2009
7,675
1,559
USA
OK this is weird

Won a 40GB portable hard drive off ebay for like 10 bucks shipped. Yeah I know its small but it works.

Hooked it up to the sathawk and formatted it as FAT32...works fine

Hook it up to the azbox and it lights up when you power on the azbox but then wont show up when you select drive. There are 2 power cords on it
green one that says "power & data"
blue when that says "power only"

The green one works fine on the sathawk....wonder why the azbox wont accept the drive?

Anybody used a portable drive on the azbox? I have a WD 320GB one that works fine but that is plugged into a/c

I have a WD 320 "My Passport" drive that is powered by the USB port and it works fine. But, it won't work when connected thru a USB hub.

Walmart.com: Western Digital 320GB My Passport Essential Portable External Hard Drive, Black: Computers
 
AcWxRadar

AcWxRadar

SatelliteGuys Pro
Apr 26, 2006
4,575
4
40 miles NW of Omaha. Omaha?
interesting....I tried both ports on the azbox and nothing.

Maybe I'll try both USB ports from the HD but that kinda defeats the purpose if I need to hog both USB ports

yep just tried both USB ports into it and it does recognize it now. I'd have to reformat it because it shows as a NFTS now (weird...it was formatted as a FAT32)

That is very odd and as you say, it kinda defeats the purpose to hog both USB ports for just a 40 GB HD. But, then again, it isn't bad for the price!

As for the formatting, the Sathawk and the AZBox must format drives just a little different. It may actually be FAT32, but there may be something slightly unique about the process of each and the AZBox just doesn't quite recognize it properly, so it just assumes that it is NFTS. Hmmm??? I need one of those little "smiley" icons that shows him scratching his head to insert here.

I guess next time try all options before asking ;)

But, then we wouldn't learn as much because we wouldn't have had to think about it along with you. When we think and ponder the situation ourselves, then we remember the solution better, as opposed to you finding the answer and just posting it. This way, it plants ideas in our heads. :)

RADAR
 
Jim S.

Jim S.

When someone asks you if you're a god, you say yes
Lifetime Supporter
Jan 2, 2006
5,475
975
FN11od
I have a drive that 3/4 of the ports on my computers won't power adequately. Nor will my Coolsat 7000. The light comes on but it doesn't spin. It works fine on the SatHawk. Prior to getting the SatHawk, I tried a "Y" USB cable, but it still didn't work reliably. I ended up ripping out the drive and putting it in a different enclosure that had an external power adapter. What's truly stupid about the whole affair is that the original, extra-power-hungry enclosure didn't even come with a Y-cable, never mind a power supply. That's what I get for buying it from a bargain site.
 
M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
I have a WD 320 "My Passport" drive that is powered by the USB port and it works fine. But, it won't work when connected thru a USB hub.

mine isnt a portable. Its one of those desktop ones that is used for a backup drive normally
 
M

Mr Tony

Thread Starter
SatelliteGuys Pro
Supporting Founder
Nov 17, 2003
312
59
Mankato, MN
That is very odd and as you say, it kinda defeats the purpose to hog both USB ports for just a 40 GB HD. But, then again, it isn't bad for the price!
yep. It will probably just be used for the Sathawk since the 320GB dive I have is formatted for Linux.
The drive is in very good shape and was dirt cheap :)

As for the formatting, the Sathawk and the AZBox must format drives just a little different. It may actually be FAT32, but there may be something slightly unique about the process of each and the AZBox just doesn't quite recognize it properly, so it just assumes that it is NFTS. Hmmm??? I need one of those little "smiley" icons that shows him scratching his head to insert here.
yeah its weird because my thumb drive shows as FAT32 when I put it in the azbox. So it does recognize FAT32 normally
 

Similar threads

Lone Gunman
Replies
14
Views
5K
AcWxRadar
AcWxRadar
S
Replies
1
Views
1K
lange
L
Crocodile Locke
Replies
24
Views
5K
AcWxRadar
AcWxRadar
xxtornxx
Replies
20
Views
10K
Apprentice
Apprentice
Top