Confused Roady XT (1 Viewer)

Whynow

Thread Starter
New Member
May 14, 2017
2
1
Woodbridge, VA
I’m hoping someone can help me out. I have a Delphi RoadyXT. I use it exclusively in my home and chose it because with its FM broadcast capability I can tune in to it from radios all over the house. Lately, when I plug it into the docking station it flashes on for a second as if it were going to power up and then goes dark to power off only to flash on again as before. This cycle repeats endlessly and none of the buttons have an effect on it. If I take the radio out of the dock and connect the power directly to it the power comes on and stays indefinitely. It loads and recognizes the last station played and then asks for an antenna connection. I have put it into three different docking stations (two home and one car) and the same thing happens where the power flashes on then off repeatedly. However, if I disconnect the antenna from the dock it behaves just as when the power was plugged into the unit out of the dock. Connecting three different antennas (one home and two car) all get the same result – flashing power. All of the attachments, docks and antennas are Delphi supplied accessories and none are aftermarket. So, I’m stumped. Any help would be appreciated. Thanks
 

Tampa8

Supporting Founder
Pub Member / Supporter
Lifetime Supporter
Sep 8, 2003
17,967
7,416
Tampa/Eastern Ct
I’m hoping someone can help me out. I have a Delphi RoadyXT. I use it exclusively in my home and chose it because with its FM broadcast capability I can tune in to it from radios all over the house. Lately, when I plug it into the docking station it flashes on for a second as if it were going to power up and then goes dark to power off only to flash on again as before. This cycle repeats endlessly and none of the buttons have an effect on it. If I take the radio out of the dock and connect the power directly to it the power comes on and stays indefinitely. It loads and recognizes the last station played and then asks for an antenna connection. I have put it into three different docking stations (two home and one car) and the same thing happens where the power flashes on then off repeatedly. However, if I disconnect the antenna from the dock it behaves just as when the power was plugged into the unit out of the dock. Connecting three different antennas (one home and two car) all get the same result – flashing power. All of the attachments, docks and antennas are Delphi supplied accessories and none are aftermarket. So, I’m stumped. Any help would be appreciated. Thanks

I just saw your post probably too late but the problem is the antenna plug on the radio or possibly the circuit for the antenna. From your description you need a new radio or find a used one like you now have. I liked that model because I could pick the color of the screen.
 

Whynow

Thread Starter
New Member
May 14, 2017
2
1
Woodbridge, VA
Thanks Tampa8 for your reply. I did wind up buying a new receiver. I was able to find an older model Roady for $10 and connected it to an FM transmitter I bought. Since I was only using it in my house this setup works even better than the, now dead, RoadyXT because the stand alone FM transmitter has greater coverage. Everyone is happy again and all for about the same price as a new RoadyXT.
 
  • Like
Reactions: Tampa8

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top