Netflix Broken (Again?)

Scion142

Thread Starter
Member
Oct 19, 2016
14
2
Sunland, California
I noticed that the software on my Hopper 3 was updated to the latest version on January 26th and that the EPG now includes both the Netflix and Youtube apps. However, when starting Netflix, the opening Netflix screen gets "stuck" and the audio from the currently tuned channel continues to play in the background. The only fix is to hard reset the receiver. Anyone else experienceing this? The app was working perfectly fine before this update. There is nothing wrong with my internet connection......
 

kwindrem

SatelliteGuys Pro
May 5, 2006
644
127
I noticed that the software on my Hopper 3 was updated to the latest version on January 26th and that the EPG now includes both the Netflix and Youtube apps. However, when starting Netflix, the opening Netflix screen gets "stuck" and the audio from the currently tuned channel continues to play in the background. The only fix is to hard reset the receiver. Anyone else experienceing this? The app was working perfectly fine before this update. There is nothing wrong with my internet connection......
I'm having many issues with Netflix on my H3 including it getting stuck on the opening screen.

I'm also seeing Netflix fail to switch to UHD. I have the most success switching to UHD the first time I enter Netflix after a reboot but after that, the system remains at HD rate.

Netflix also looses it's log-in settings forcing me to reenter user name and password.

It seems these issues have gotten worse with U336 and U341.

My LD OLED TV streams Netflix and works every time so I use it instead. The TV also supports Dolby Vision for the few Netflix titles that have it. Dolby Vision is probably something that the Dish receivers will never do since special hardware (and a license) is required to unravel Dolby Vision enough to send it on to the TV.
 

KAB

SatelliteGuys Master
Pub Member / Supporter
Lifetime Supporter
Sep 20, 2005
20,339
3,678
Indy
I'm having many issues with Netflix on my H3 including it getting stuck on the opening screen.
I've had the same thing happen...on my ROKU! Was really bad late last week. Kept having to reboot. So, that points to a problem with Netflix.
 

Scion142

Thread Starter
Member
Oct 19, 2016
14
2
Sunland, California
I did re-set Netflix under the Tools tab prior to attempting to open the app the second time on the H3. Still no luck. Like the prior poster indicated, I will just rely on the the built-in Netflix app on the Samsung (this is a 4K set) rather than trying to deal with the Hopper issues. My suspicion is the "updated" Netflix app on the Hopper can't negotiate a connection to my set even though I'm using the HDMI 2.0/HDCP compliant connection on the TV and it all worked perfectly until this latest update.
 

shadlom

SatelliteGuys Guru
Apr 3, 2015
123
59
United States
I'm having many issues with Netflix on my H3 including it getting stuck on the opening screen.

I'm also seeing Netflix fail to switch to UHD. I have the most success switching to UHD the first time I enter Netflix after a reboot but after that, the system remains at HD rate.

Netflix also looses it's log-in settings forcing me to reenter user name and password.

It seems these issues have gotten worse with U336 and U341.

My LD OLED TV streams Netflix and works every time so I use it instead. The TV also supports Dolby Vision for the few Netflix titles that have it. Dolby Vision is probably something that the Dish receivers will never do since special hardware (and a license) is required to unravel Dolby Vision enough to send it on to the TV.
Yea, the h3 supports hdr10 but the Netflix app hasn't been updated to take advantage yet.

Sent from my Nexus 6P using the SatelliteGuys app!
 

robre

SatelliteGuys Family
Jun 10, 2006
46
0
I am having issues getting 4k using the Netflix app on my hopper 3. I know the hopper can see my TV is 4k, as it displays 4k when I do the PIP 4 channell view. With the latest update U343, it started to display 4k Netflix programs in 4k, and I thought all was wll, but after doing some things, including some diags, it stopped again, and then did not show any programs in info as 4k. I reset the hopper and then it would show in info that 4k program were UHD, but when they played, they only displayed at 1080i. I reset the Netflix app as well with no change. I can do 4k Netfix casting to my Vizio 4k TV and from my Fire TV, but not from the dish Netfix app. The fact that it did temporarily work yesterday, I know is should work. It seems like it is a bug in the Neflix app. Is anybody else having the issue, or does anybody know how to fix it? I have in settings to automatically display 4k if it is available.
 

kwindrem

SatelliteGuys Pro
May 5, 2006
644
127
I am having issues getting 4k using the Netflix app on my hopper 3. I know the hopper can see my TV is 4k, as it displays 4k when I do the PIP 4 channell view. With the latest update U343, it started to display 4k Netflix programs in 4k, and I thought all was wll, but after doing some things, including some diags, it stopped again, and then did not show any programs in info as 4k. I reset the hopper and then it would show in info that 4k program were UHD, but when they played, they only displayed at 1080i. I reset the Netflix app as well with no change. I can do 4k Netfix casting to my Vizio 4k TV and from my Fire TV, but not from the dish Netfix app. The fact that it did temporarily work yesterday, I know is should work. It seems like it is a bug in the Neflix app. Is anybody else having the issue, or does anybody know how to fix it? I have in settings to automatically display 4k if it is available.
I'm experiencing similar issues. When things are working, the Netflix app switches to UHD when it starts up. At best, that happens the first time the app is started after an H3 reboot. After that, entering the Netflix app remains at HD rates.

The first time after H3 reset that the Netflix app starts up, it may simply hang. Exiting and reentering Netflix may hang or may come up in HD.

This situation has definitely with the U342 update compared with U334. I noticed my H3 is at U343 this morning but haven't tried Netflix yet.
 

robre

SatelliteGuys Family
Jun 10, 2006
46
0
I have had that hang as well where I get a black screen no/video when entering Netflix. I was real happy when it the UHD started working after the U343 update, only to be disappointed when the issue came back. Luckily I have a backup way of watching Netflix in 4k, but it sure would be nice if it worked correctly on the Hopper so that it would be easier.
 

kwindrem

SatelliteGuys Pro
May 5, 2006
644
127
I'm experiencing similar issues. When things are working, the Netflix app switches to UHD when it starts up. At best, that happens the first time the app is started after an H3 reboot. After that, entering the Netflix app remains at HD rates.

The first time after H3 reset that the Netflix app starts up, it may simply hang. Exiting and reentering Netflix may hang or may come up in HD.

This situation has definitely with the U342 update compared with U334. I noticed my H3 is at U343 this morning but haven't tried Netflix yet.
One other thing: The Netflix app likes to forget my login info forcing me to enter account and password info. Typically happens after a black screen hang but have seen it other times.

I've given up on Netflix on H3 and use the app in my LG TV instead. I get HDR and Dolby Vision when the program offers it, no hangs and no forgetting login info.

There are so many streaming services available today, offering just one (Netflix in this case) hardly eliminates the need for a dedicated streaming box. Even Ultra Blu-Ray players seem to be offering fewer streaming choices. Oppo's UDP-203 has NO streaming services. The TV has a pretty wide range of streaming services but the down side is there's no way to get high-end audio (Dolby Atmos, DTS:X or even Dolby Digital Plus) out of the TV. I don't mind minimizing boxes in my system but manufacturers need to put out a solid app, not something as flakey as Netflix on the H3. It's after all not in Dish's main stream to support streaming big time. And it would need to support many more services. A dedicated streaming box seems the only workable solution to streaming.
 

DCUNY

SatelliteGuys Family
Pub Member / Supporter
Nov 7, 2016
85
21
Rochester, NY
I'm on U343 and am still getting the "pink screen of death" when the H3 Netflix app tries to talk to the TV in 4K mode. It is an HDMI handshaking problem. If I go over and unplug, then replug the HDMI cable into the TV the Netflix app displays.

Sometimes the TV is in 2160P, but most of the time it's still in 1080i.

Definitely a problem somewhere in the software as none of my other devices act like this.
 

robre

SatelliteGuys Family
Jun 10, 2006
46
0
Well, I did not do anything, and my Netflix started working with 4k programming for the last several days. Very strange but I am happy it is.
 

Scion142

Thread Starter
Member
Oct 19, 2016
14
2
Sunland, California
I haven't had any issues with Netflix on the Hopper 3 since managing to fix my issue by following the helpful directions included in this thread. What I have also found helpful when using the Netflix app is to allow it to open and then go to Account Settings, Get Help, and hit "Reload Netflix." This resets the bitstream for the app and often enables UHD content to load properly. It has worked with my setup and is needed even with a 60+mbps internet connection.
 

robre

SatelliteGuys Family
Jun 10, 2006
46
0
I continue to have issues with Netflix. I figured out a trick to get it to play 4k movies in 4k. If I go to a 4k channel (540) and then run the Netflix app, it plays 4k movies correctly. Also, I cannot get it to pass Dolby Digital sound (through HDMI), even though it works correctly for normal Dish channels.
 

Bobby

Publican
Supporting Founder
Lifetime Supporter
Sep 7, 2003
58,628
11,841
Rohnert Park, CA
I continue to have issues with Netflix. I figured out a trick to get it to play 4k movies in 4k. If I go to a 4k channel (540) and then run the Netflix app, it plays 4k movies correctly. Also, I cannot get it to pass Dolby Digital sound (through HDMI), even though it works correctly for normal Dish channels.
The audio issue has been around since the very beginning of Netflix on Hoppers. The only way to get 5.1 is to use an optical cable.
 
  • Like
Reactions: Troch77

robre

SatelliteGuys Family
Jun 10, 2006
46
0
My hopper updated to 344 yesterday, and Netflix seems to be displaying 4k reliably now. The Netflix app also seems to pad up a lot faster to me. My Visio TV received a firmware update as well. But the Hopper update I assume fixed the issue. Now if they would only fix it so that Dolby Digital worked with Netflix, that would be great.
 

DCUNY

SatelliteGuys Family
Pub Member / Supporter
Nov 7, 2016
85
21
Rochester, NY
My hopper updated to 344 yesterday, and Netflix seems to be displaying 4k reliably now. The Netflix app also seems to pad up a lot faster to me. My Visio TV received a firmware update as well. But the Hopper update I assume fixed the issue. Now if they would only fix it so that Dolby Digital worked with Netflix, that would be great.
Do you happen to have a Joey 2.0, and if so did the software on the Joey get updated too? Thx
 
Oct 21, 2016
13
2
rochester mn
My NETFLIX hangs EVERY SINGLE TIME when brought up on the Hopper3 box....I hear audio from previous channel but it never gets the swirl and starts NETFLIX ....
I don't have a 4K TV. The NETFLIX on the joey is jumpy.
This is not impressive.
When this happens I will hit the reset button on the Hopper3 and it may work or may hang again.
This is not impressive. Is there any workaround to get this to work reliably ?
Thanks much !
 

Bobby

Publican
Supporting Founder
Lifetime Supporter
Sep 7, 2003
58,628
11,841
Rohnert Park, CA
Go to Menu (Home), Settings, Diagnostics, Tools, Reset To Factory Defaults, Reset Netflix to Defaults. That should fix you up.
 

Users Who Are Viewing This Thread (Total: 1, Members: 0, Guests: 1)

Top