Problems with Audio on HD Channels

Status
Please reply by conversation.
G

grusome

Thread Starter
SatelliteGuys Pro
Aug 2, 2006
184
0
Been experimenting with HD using ProgDVB & Twinhan 1020a.
Installed on a P4 3.0Ghz, w/512megs ram & Gforce3 Video Card w/128Megs ram. Video is great on AMC3 PBS and Nimiq2 HD Promo channel. BUT, the audio sounds like someone that has inhaled helium and stutters!! On regular channels, the audio is normal. I have changed every setting that I can find for the Audio & Video settings and none seem to effect the sound at all. Using ProgDVB 4.79 Full, with the Intel P4 patch ( dll) installed. My sound system is an on-board VIA AC97 audio chipset. Any suggestions would be greatly appreciated.
(oh, and my cpu usage is around 24% +- ........much better than the previous system I had the Twinhan installed in)
grusome
 
G

grusome

Thread Starter
SatelliteGuys Pro
Aug 2, 2006
184
0
Thanks for the links. I'm not sure what Gspot is supposed to do. I load it and it doesn't show anything like the screenshots that show a list of codecs etc. I have Windows Media Player 10 Installed. As I said, the audio is fine on regular SD channels, but, has problems on the HD channels. Maybe, the onboard audio doesn't support AC3 audio that well. I have looked for updated drivers and not found anything newer than what I already have.
grusome
 
damaged

damaged

SatelliteGuys Pro
Jun 22, 2005
2,605
1
South of Heaven
grusome said:
Thanks for the links. I'm not sure what Gspot is supposed to do. I load it and it doesn't show anything like the screenshots that show a list of codecs etc. I have Windows Media Player 10 Installed. As I said, the audio is fine on regular SD channels, but, has problems on the HD channels. Maybe, the onboard audio doesn't support AC3 audio that well. I have looked for updated drivers and not found anything newer than what I already have.
grusome

Opps left out one important link:
http://www.softella.com/dsfm/index.en.htm


With gspot, you load up a file with that uses the same audio codec as the player software does for HD audio (AC3), load it up in gspot and it will tell you which codec chain/order it's using, you can then determine if it is the optimum codec chain that should be handling this, if not you can change it to the default windows one with the directshow filter manager (url above), for example, some software installs codec packs which change the priorty of codecs, and can break things, sometimes just replaces the codec chain with more inefficient ones, such as Neros codecs.

A HD stream would probably use different codecs than a SD stream, so that is why I suggested the codec fix.
 
Last edited:
G

grusome

Thread Starter
SatelliteGuys Pro
Aug 2, 2006
184
0
Thanks for the additional link. That certainly showed a lot of codecs installed on my system. I did not see anything about AC7 in the list, just AC3. So, maybe that is where the problem lies. I will do a search to see if I can find something that will render it correctly.
grusome
 
damaged

damaged

SatelliteGuys Pro
Jun 22, 2005
2,605
1
South of Heaven
grusome said:
Thanks for the additional link. That certainly showed a lot of codecs installed on my system. I did not see anything about AC7 in the list, just AC3. So, maybe that is where the problem lies. I will do a search to see if I can find something that will render it correctly.
grusome

Opps typo, I meant AC3.
 
G

grusome

Thread Starter
SatelliteGuys Pro
Aug 2, 2006
184
0
Update!! Got AC3 audio finally working good. Not full volume......only have two front speakers and subwoofer, but certainly loud enough that I can listen(and watch) PBS HD without the high pitched voices and stutters. The links you provided got me pointed in the right direction. And a friend sent me a link to a codec package that included some better stuff for the HD video. Now, I need to do two things, get better speakers and probably a larger dish as I can only get about 30% Quality on AMC3 on the PBS HD channel going thru the bypass of my Pansat 2700a.
Thanks for your help damaged!!
grusome
 
damaged

damaged

SatelliteGuys Pro
Jun 22, 2005
2,605
1
South of Heaven
grusome said:
Update!! Got AC3 audio finally working good. Not full volume......only have two front speakers and subwoofer, but certainly loud enough that I can listen(and watch) PBS HD without the high pitched voices and stutters. The links you provided got me pointed in the right direction. And a friend sent me a link to a codec package that included some better stuff for the HD video. Now, I need to do two things, get better speakers and probably a larger dish as I can only get about 30% Quality on AMC3 on the PBS HD channel going thru the bypass of my Pansat 2700a.
Thanks for your help damaged!!
grusome

NP, good to hear (no pun intended).
 
Status
Please reply by conversation.

Similar threads

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top