Unable to Reply to Posts?

Scott Greczkowski

Welcome HOME!
Original poster
Staff member
Cutting Edge
Sep 7, 2003
Newington, CT
Are you trying to reply to a post, but the post reply box is empty?

This morning on April 30th doing normal while doing normal militance I was updating the plug ins used by our forum software. This is an automated process where it tells me there are updates available and asks me if I want to install them, and I just click YES and they update.

Well this morning I did that and it caused an issue where the people who were online at that time could not reply to any posts, as the reply box was empty and the system wouldn't let you type into the box.

IF you are unable to reply and still see a blank reply box, you will need to clear your cache... depending on the browser you use there are a few ways of doing it. Here they are...

  1. Chrome, Firefox, or Edge for Windows: Press Ctrl+F5 (or try Shift+F5 or Ctrl+Shift+R).
  2. Chrome or Firefox for Mac: Press Shift+Command+R.
  3. Safari for Mac: Press Command+Option+E to empty the cache, then hold down Shift and click Reload in the toolbar.
  4. Right-click anywhere on the page and choose Inspect, then press and hold the Refresh Icon and select "Empty Cache and Hard Reload" from the dropdown.
  5. Google Chrome or Firefox for Windows: Hold down Ctrl and then press F5 on your keyboard
So why did this happen? (Time to get technical)

Our Forum software we use is about to come out with a major update which is 2.3. This 2.3 software is currently in beta testing and is not advised for live sites like ours. Our current software version is 2.2.

Anyways the author of the plugin put the wrong file in an update which was mean for the 2.3 beta and not for 2.2. When we updated it copied the new file and overwrote correct file here on SatelliteGuys, this caused the reply box to stop working. The file that was replaced was a javascript which was jscript.slim.min.js which was version 3.7.1 when the file our software needs is 3.3.1. I had to find the 3.3.1 version and replace it on the server. I also had to clear the cache on our server as well as on our cloud CDN servers. Once that was done unfortunately the people who were online at the time the bad script was installed had to clear their cache to have things function properly again. Those who were not online at the time were not affected.

I contacted the author of the plugin and he told me he immediately updated the file with the correct version of the JavaScript almost immediately after he updated the bad one. And as far as he knows I was the only one to download and install the bad file.

So if you had to clear your cache to reply to any posts here, my humble apologies.

On the topic of the upcoming Xenforo 2.3 software, I am both excited and nervous about it.

I am excited about it as there is so much improvement in it as well as new features such as...
The things I am nervous about are there are reports some addons may not work with 2.3. I am worried some of our add on's may not work in 2.3 nor will they be updated by the authors for 2.3. Some of our addons were custom written for us, and others are simply not supported anymore as the authors are not around anymore.

Anyways that is what happened... so if you are logged in and can't reply to anything... clear your cache... :)

Sorry again for the issue.
I thought it was just me. Then I tried Edge and no problem. I'm still unable to post in Chrome. Doing this post in Edge.

I also agree that in Chrome I have the long "clocking times" now too.

Anyway, thanks Scott for posting this. Not sure what to do about Chrome but maybe if I wait it will fix itself.

Haven't tried to clear cache. I'll try that next.
  • Like
Reactions: charlesrshell
I am playing at the moment... this one is agrivating as the logs are showing nothing...

I need to catch it as its doing it and see if its a SatelliteGuys software issue, or a different issue.
  • Like
Reactions: charlesrshell
This may be the same issue we had on the old server... Where the resolver keeps getting changed back to the ISP's resolver instead of the ones I am specifying...

I remember I had to make it immutable before so it would stop being overwritten.

We just had the pause issue a few minutes ago and I was logged in via SSH and was unable to reach the ISP's resolvers... I updated our resolver file to point elsewhere and things were back to being quick again. But also as I did that the ISP's resolver was reachable again as well...

Thank god I lost my. hair or I would be pulling it out by now. :D
Hey and that time it went down I did get error messages... I may be cooking with gas here...

[*]ErrorException: Push notification failure: cURL error 28: Resolving timed out after 10000 milliseconds (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)
  • Like
Reactions: charlesrshell
Hey Scott- It's back on it's own. I just went away from the computer to do my daily 2 hour exercise routine and now it is back.

Sure glad I never became a software developer.
Yeah sounds like the cache cleared on its own. Cache on the computer is only stored for a certain amount of time, depending on the file type it may last a few hours, or a few years. Caching keeps you from having to download the same thing over and over and over again each time you reload a page.

So for Example, Instead of your computer downloading our 95k SatelliteGuys logo on each page load, that logo is cached on your computers browser. so when you load any page your computer is like... hey I already have that logo file, so i will display it from local cache instead of downloading the 95k logo again. Images are catched longer then other things. But I believe Javascripts are only cached for a few hours.

That explains why it fixed itself.

Before starting this site I didn't know any of this stuff. And now I am dangerous with what I know, lol!
Ahhh... I feel a lot better now then I did about an hour ago...

And I learned that the resolv.conf file reverts back to what the ISP sets everytime you reboot the machine.

So I made the changes to it and made it immutable and (fingers crossed) that fixes the issue once and for all. (It did on the old server.)

It seems as though our ISP's resolver has issues. So lets not use them anymore.

With that said I also think the DNS changes I made on Saturday fixed the Oops problem as well.

Once again I have my fingers crossed. :)

Google Maps

Dish Installers