External USB HDD and RESERVE RECORD setup via MaZEdit (BUG/GLITCH)



Thread Starter
SatelliteGuys Pro
Apr 26, 2006
40 miles NW of Omaha. Omaha?
Hey folks, I hope everyone is well.

Recently I stumbled upon a possible BUG with my AZBox and MaZEdit. After I discovered it, I performed quite a few tests and trials to evaluate the situation. I obtained the same results each time. I have some more testing and troubleshooting to perform, but I thought I would keep you abreast of the situation thus far. This is an FYI item just in case you stumble upon the same issue.

I have an AZBox Premium Plus with a 1TB internal Samsung HDD installed and an external USB Maxtor 750GB HDD attached to the rear USB port. My 1TB internal HDD is 100% FULL!

I have a second 1TB Samsung HDD that I am using to record more movies to, but I swap these two internal drives in and out depending upon what recorded programs I want to watch. Currently, I have the FULL HDD inside the AZBox.

Recently, we got into a discussion about the PBS programs in the FTA SHACK and I wanted to record several of the upcoming episodes.

I have always used MaZEdit to set up my recording events because I can set the record start time and record duration to the precise minute and also type the program title in right from my PC (instead of doing so with the remote). After creating the record schedule using MaZEdit, I upload that to the AZBox and the box reboots and voila, the record event is stored in the AZBox.

When I set up the RECORD EVENT in MaZEdit, there is a box to select the recording destination. It shows the internal HDD and the attached external USB HDD. I select the external USB HDD and all the other parameters for the event (start time, date, channel, duration etc) and that is what is uploaded to the AZBox.

Here is where things get messed up.

After the upload and reboot process, I go and check the RECORD EVENT TIMER to ensure that it reflects all the data accurately. I find everything to be correct, but it shows the destination drive to be the HDD. HDD reflects the internal storage device, not the external one. It should have shown USB1-2.

I believe that USB1-2 means the first USB device detected [USB1] and it is connected to the rear USB port or port #2 [-2], hence USB1-2. If I plug another USB device in at the front port, the AZBox detects it as USB2-1. I assume that this means, the second USB device detected and it has been found on the front or #1 port. Makes sense? Good enough I think.

So, I attempt to alter this destination drive by using the remote and the AZBox record event menu to change the selection to USB1-2.
It allows me to change the destination drive to USB1-2, but it won't save it as such. It remains as HDD. I allowed it to attempt to record the event with this setting as-is. The event started, but then popped up with an error message that the drive was full and it wouldn't allow the recording to proceed.

This is correct (the internal HDD was full). So, at least I know that I cannot inadvertently overwrite any of the movies and programs on my internal HDD. It won't let you if the drive is full. This is nice information to know and I am happy to find out that it operates this way. However, I didn't make a mistake in selecting the wrong destination drive. I selected the USB1-2 drive, not the HDD internal drive!

Please stay with me, this is a little confusing and it gets worse.

So, I next tried to set up a test recording using the remote and the AZBox RESERVE RECORD/PLAY menu option. I selected USB1-2 as the destination and when the record event began, it functioned properly and recorded the show to the USB1-2 device. I tried it again and this time I reviewed the record event parameters prior to the recording to see what destination device it showed. Guess what? It showed HDD (not USB1-2). But, it still recorded to USB1-2! Do you see why I myself am confused?

I tried this repeatedly using MaZEdit and then the remote and it worked out the same each time.

I still have some options to test, but don't think I will get to them for a few days. I need to test the setup of a recording timer using MaZEdit with the NOT FULL internal HDD installed and then test it with NO internal HDD installed at all. Another test will be to perform all the same tests with a different USB HDD than the one I am using, maybe trying several different drive species/mfgs.

My preconclusion thus far is that using MaZEdit to set up a recording event with an external USB HDD as the destination is not working appropriately (at least not with the specific USB HDD that I have connected) as it seems to default to the internal HDD and once the record event has been uploaded to the AZBox, the destination device cannot be altered or adjusted appropriately. It does, however, work properly if I use the remote and the AZBox record event menu (except it still shows the HDD as the destination and I can't figure that one out).

Sorry if this is confusing, but I cannot find a way to describe it in shorter words or more eloquently than this. If I cut it down at all I would be omitting pertinent facts.

If anyone has information to add, please respond. Surely someone else has an AZBox with an external USB HDD and has used MaZEdit to set up a recording event. I would even like to hear from those who have an AZBox model that only supports an external HDD.

Well, that is all for now. I will report back when I find something new or get the results of my future troubleshooting trials.



SatelliteGuys Family
Jun 25, 2009
The OC
I believe that USB1-2 means the first USB device detected [USB1]

Not sure this is pertinent to what you're troubleshooting, but in my case if I had a USB device in both ports, my Premium would always detect the device (memory stick) in the front panel port first and call it USB1. I had to remove it and reboot to force the AZBOX to identify the rear port device (HDD) as USB1. If I set up the timer when the front device wasn't present, but it *was* present and the box had since been rebooted at the time the recording was to take place, it canceled the recording due to lack of space. That quirk prompted me to install an internal drive that's independently identified. No missed recordings since.

Similar threads

Magic Static

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)