Fortec Star Mercury II DOA. Though I hope not

Status
Please reply by conversation.
ussexplroer

ussexplroer

Thread Starter
SatelliteGuys Pro
Feb 17, 2007
272
4
Well I got my Fortecstar from Gosat. But it appears DOA. Anything to try before requesting a rma?

I tried the following:

Different outlets.
Remote
Front power button
Triple checked the back on and off switch.

Just nothing, no hum, no light, no nothing. Something I'm missing? All of my other fta receivers just come on and work.

Thanks,

josh
 
L

Lak7

SatelliteGuys Master
Pub Member / Supporter
Feb 28, 2008
5,451
7
Near Chicago, Illinois
Make sure it's Un-plugged!
Take the cover off and check fuse and connections to the On / Off switch.
 
ussexplroer

ussexplroer

Thread Starter
SatelliteGuys Pro
Feb 17, 2007
272
4
I got it

I got it. I didn't want to do it. But I got it.

I removed the cover and found the power connector from the power supply
to board slightly unpluged. Like half way off. So I pushed it back on and it locked into place. Sortof locked. You know how some of those plastic locks sucks. Seems to work fine now.

I just hate to do that stuff because of warrenty. Sure I have worked in computers over 10+ years so I know exactly what I was doing. But it is kind of a code of honor when under warrenty.

I just didn't want to ship it back for something simple.

Thanks,

Josh

If you want you can remove this post or stick it with my other post. I was freaked out for about 1 hour.
 
T

tvropro

On Vacation
Mar 9, 2007
6,872
0
I got a Fortec Star Mercury 2 for a client once and noticed something rattling inside. I found a piece of a pc board in there. I removed it before applying power.
 
Status
Please reply by conversation.

Similar threads

PKII
Replies
6
Views
2K
concord
concord
PKII
Replies
9
Views
2K
brentb636
brentb636
M
Replies
7
Views
1K
updatelee
updatelee
C
Replies
6
Views
1K
Larobpra
Larobpra
drhydro
Replies
2
Views
1K
Sadoun
Sadoun

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top