Optoma HD23 Blower Failure

TheTechGuru

TheTechGuru

Thread Starter
SatelliteGuys Pro
Original poster
Oct 30, 2010
1,847
221
Texas
HD23, 5652 hours on the unit, 82 hours on the current bulb.


I can hear the blower make the dreaded bad bearing grinding noise that bad computer fans make. I get the fan failure message anywhere from 5 minutes to 30 minutes after powering it on depending on the room temp and humidity that day I guess.


So I ordered a new blower from China on ebay (it's all I could find). Month later, put the new one in and get fan failure as soon as I turn it on even though I have visually verified that it is running. So it get out my DMM and put it in Hz mode and check the pulse output and it's 0. I bench test the factory fan and it shows about 265hz when running it on 12v. I oiled the factory blower and reinstalled it and got about 10 more minutes of run time out of it. I got the ebay seller to refund me and ordered another one from China from a different seller. Month later get it installed and the same as the first. Fan failure as soon as I turn it on.

Am I missing something or do all these Chinese fans have a defective sense output? I read the service manual and even tried the Calculate W_factory procedure.

Is there any alternative to the factory SUNON GB1245PKVX-8 that I could use? I can't even find anything at Mouser.


I really want to save this projector, even if that means coming up with a way to bypass the fan detection (since the 2 new fans do blow, just don't have a proper sense output). The color is still perfect after all these years and I'm in no position to buy a new projector since the pandemic put my business out of business causing. I was not planning to get a new one until I can afford a 4K DLP w/Laser light source which will be quite a while thanks to the pandemic.


Any advice on where to get a proper working blower or how to override the auto shutdown would be appreciated.
 
FTA4PA

FTA4PA

Satellite Guys Family
Lifetime Supporter
Nov 13, 2013
6,352
4,342
Central Pennsylvania
HD23, 5652 hours on the unit, 82 hours on the current bulb.


I can hear the blower make the dreaded bad bearing grinding noise that bad computer fans make. I get the fan failure message anywhere from 5 minutes to 30 minutes after powering it on depending on the room temp and humidity that day I guess.


So I ordered a new blower from China on ebay (it's all I could find). Month later, put the new one in and get fan failure as soon as I turn it on even though I have visually verified that it is running. So it get out my DMM and put it in Hz mode and check the pulse output and it's 0. I bench test the factory fan and it shows about 265hz when running it on 12v. I oiled the factory blower and reinstalled it and got about 10 more minutes of run time out of it. I got the ebay seller to refund me and ordered another one from China from a different seller. Month later get it installed and the same as the first. Fan failure as soon as I turn it on.

Am I missing something or do all these Chinese fans have a defective sense output? I read the service manual and even tried the Calculate W_factory procedure.

Is there any alternative to the factory SUNON GB1245PKVX-8 that I could use? I can't even find anything at Mouser.


I really want to save this projector, even if that means coming up with a way to bypass the fan detection (since the 2 new fans do blow, just don't have a proper sense output). The color is still perfect after all these years and I'm in no position to buy a new projector since the pandemic put my business out of business causing. I was not planning to get a new one until I can afford a 4K DLP w/Laser light source which will be quite a while thanks to the pandemic.


Any advice on where to get a proper working blower or how to override the auto shutdown would be appreciated.
Have you tried contacting Optoma USA directly for parts/service?

 
  • Like
Reactions: Foxbat
harshness

harshness

SatelliteGuys Master
May 5, 2007
17,632
3,424
Salem, OR
I bench test the factory fan and it shows about 265hz when running it on 12v.
That's an awfully high number of ticks per second. A data sheet that I downloaded from Sunon suggests that the signal output is two cycles per revolution. At two ticks per revolution that would be 7,950rpm and that's waaaay too fast.

Amazon lists a replacement:

Amazon product
View: https://www.amazon.com/wangpeng-Optoma-GT750-GB1245PKVX-8-8BW01G11-B3815-AR-X-GN/dp/B07RPDFM93


Unless you have some deep emotional attachment to this projector, I'd suggest retiring it. I'm surprised that the DLP system hasn't had some aging issues.
 
TheTechGuru

TheTechGuru

Thread Starter
SatelliteGuys Pro
Original poster
Oct 30, 2010
1,847
221
Texas
Since the SUNON blower is no longer manufactured do you think it's possible to replace it with DELTA BFB04512HD-R00 or DELTA BFB04512MD-R00 ?
 
TheTechGuru

TheTechGuru

Thread Starter
SatelliteGuys Pro
Original poster
Oct 30, 2010
1,847
221
Texas
Is the fan that I linked to on Amazon not the right fan?
The SUNON's are all used or fake clones. The amazon one is no different than the two I got from China on ebay already.

At this point I'm considering leaving in the working but no RPM output china ebay SUNON and wiring in a regular round computer fan that meets the same RPM spec and mounting it outside the projector somewhere to just run and feed the RPM pin.
 
  • Like
Reactions: Foxbat
TheTechGuru

TheTechGuru

Thread Starter
SatelliteGuys Pro
Original poster
Oct 30, 2010
1,847
221
Texas
So I bought a used fan on eBay from a part out of the same projector model AND IT WORKS!
 
  • Like
Reactions: Foxbat and FTA4PA

Similar threads

dfergie
Replies
0
Views
457
dfergie
dfergie
gadgtfreek
Replies
0
Views
736
gadgtfreek
gadgtfreek
dfergie
Replies
0
Views
590
dfergie
dfergie
dfergie
Replies
4
Views
1K
dfergie
dfergie

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Who Read This Thread (Total Members: 1)

  • TheTechGuru

Latest posts

Top