Azbox power suppy (1 Viewer)

alexanderthegreat

Thread Starter
Member
Aug 20, 2009
9
0
South
Ordered Axbox Premium HD, August 3, 2011. Powers supply died,
returned and another was sent. Now, 09-03-2011, second power supply has died. Is this a common problem? How is it fixed?
 

AcWxRadar

SatelliteGuys Pro
Apr 26, 2006
4,575
4
40 miles NW of Omaha. Omaha?
Ordered Axbox Premium HD, August 3, 2011. Powers supply died,
returned and another was sent. Now, 09-03-2011, second power supply has died. Is this a common problem? How is it fixed?

Alex,

This was a common problem a while back, when the Premiums first came out. I thought that they had it corrected by now, but you must be getting the older PS's.
THere is a thread here or several of them relating to this problem. Try the search engine here for those threads and see if you can find them. There was a way to tell if you had the older PS, but I cannot remember what the specifics were. Also, Rick's Satellite shop may be a resource for the good PS's at a fair price. Otherwise, reorder another one under warranty.

However, be sure you check your house voltage for low voltage and voltage drops/spikes. If you have a poor electrical source, it may be causing troubles. Have your electric power company check it for you if you don't have the equipment. IF they say they don't do that, then tell them to pay someone to do it for them, they are obligated. If their power feed to you is not clean, it could be hard on other equipment, like your deep freezer and refrigerator for a couple of really important items.

RADAR
 

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top