Big cookie or header error

harshness

Thread Starter
SatelliteGuys Master
May 5, 2007
16,469
2,635
Salem, OR
Today I've been getting a 400 error when using my usual browser (Firefox) about "Request header or cookie too large". The offending cookie doesn't appear to be one from www.satelliteguys.us or satelliteguys.us as if I clear all of those, the problem remains.

1597522880079.png


Does anyone have any insight as to which of the many third party cookies that the site serves up might be the offender?
 

harshness

Thread Starter
SatelliteGuys Master
May 5, 2007
16,469
2,635
Salem, OR
Have you tried clearing your cache? [CTRL][F5]
I emptied the cache but kept the cookies. I've been whacking cookies all morning. It is next to impossible to divine what sites dish up which cookies (other than the cookies under their domains). I had to do a complete purge (cache and cookies) to make Edge Chromium work.
 

harshness

Thread Starter
SatelliteGuys Master
May 5, 2007
16,469
2,635
Salem, OR
I wonder if it has anything to do with the "Privacy" settings doodad in the lower right corner of the browser.

1597559406532.png


When I click on it, I get this window. If I change the settings, it goes away but if I poke the button again, everything reverts to "On" (whether I save & exit or agree). It appears to be some rather sophisticated advertising profiling tool. If I don't hurry to agree, the 400 error pops up (perhaps on the page reload timer?).

1597559372419.png
 

Magic Static

FTA Geek
Staff member
HERE TO HELP YOU!
Lifetime Supporter
Oct 12, 2010
7,304
4,547
Montana
I'm not able to get in with Chrome or Firefox, even on a new machine that's never been to Satelliteguys or anywhere else for that matter. IE 11 and Edge are working(if you can call it that)
 

cyberham

SatelliteGuys Pro
Jun 16, 2010
2,983
834
Nova Scotia
Kind of ironic that these cookies which are supposed to be friends of website creators are in fact halting use of their website that they created.

I can't access the site at all with either Microsoft Edge or Chrome.

Sent from my SM-G950W using the SatelliteGuys app!
 

harshness

Thread Starter
SatelliteGuys Master
May 5, 2007
16,469
2,635
Salem, OR
I've been tinkering some more and the problem seems to hinge on the privacy settings as my recent post shows above. It seems to help if I avoid the button and only use the window that wedges itself up at the bottom of the screen after a few seconds.

I arrived at the determination that the site was its own worst enemy by setting the home page to www.satelliteguys.us (to avoid getting cookies from other sites) and then cleared all the cookies. There are approximately 45 domains that drop somewhere around 70 cookies on a short visit.

Even as I enter my message, I get a frequent pop-up saying something like "oops, we've encountered a problem".

Now that I've closed that message six times, the pop-up hasn't come back.
 

Scott Greczkowski

Welcome HOME to SatelliteGuys!
Staff member
HERE TO HELP YOU!
Sep 7, 2003
98,636
15,704
Newington, CT
Fixed.


Seems like others have had this issue as well over the past 24 hours.

The fix was to add the following to our Nginx config file (Nginx is our Webserver software)

"large_client_header_buffers 4 16k;"

And that solved it.

Nothing to do with the required IAB banner which is not even served by our server. I know Google adsense is getting a lot of flack from this banner from many webhosts, and are working on a new less invasive one which means EU and California standards. I hope to swap it out when the new one is available.
 

navychop

Member of the Month - July 2014!
Pub Member / Supporter
Lifetime Supporter
Jul 20, 2005
50,472
15,346
Northern VA
Try doing a “conversation” and see the fun there, too.
 

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top