HDMI VIP612 Problem

delanewf

Thread Starter
SatelliteGuys Family
Jan 20, 2005
60
0
This is my problem: I have a brand new VIP612 hooked up to a Philips TV through HDMI. Every time I turn on the TV, no picture through the HDMI. I cycle through the TV's video sources back to the HDMI source the TV was originally on and the picture comes back. All other outputs(component, composite) work on the receiver and TV. None of the 3 HDMI inputs on the TV work with the receiver. I hooked up my PS3 to the TV's HDMI and when I turn on the TV, it shows the picture immediately. This tells me the HDMI inputs on the TV are fine. The problem has to be with the receiver.

For some reason, when I power down the TV, the receiver loses its connection to the TV. Once I turn on the TV and cycle to the same HDMI input, the picture comes back.

Does anyone know if there is a fix to this? Has anyone heard about this problem before? Is there any menu options that need to be turned on or adjusted on the receiver?

Thanks in advance.
 

navychop

Member of the Month - July 2014!
Pub Member / Supporter
Lifetime Supporter
Jul 20, 2005
55,208
20,708
Northern VA
"For some reason, when I power down the TV, the receiver loses its connection to the TV. "

Is that what you meant to say? Of course the connection is broken if one of the devices is turned off.
 

TheKrell

A mighty and noble race originating on Altair IV.
Pub Member / Supporter
Jan 4, 2007
35,472
32,814
Fairfax, VA
FWIW I do not observe this problem on either of my 612's. They feed a Samsung monitor and a Vizio.
 

delanewf

Thread Starter
SatelliteGuys Family
Jan 20, 2005
60
0
"For some reason, when I power down the TV, the receiver loses its connection to the TV. "

Is that what you meant to say? Of course the connection is broken if one of the devices is turned off.

I am sorry if you did not understand what I was trying to say. I will try again. The receiver is not "remembering" it is connected via the HDMI cable. I have to "remind" it by cycling to the HDMI input again from the TV. Once the TV sends the input source to the receiver, it connects and I get a picture. Every other Dish receiver I have connected to my other TVs "remembers" automatically, without me having to reset the input source.
 

Teehar

SatelliteGuys Master
Pub Member / Supporter
Sep 29, 2010
8,355
174
WNC
My guess is the hdmi output on the 612 is starting to fail.I have had that happen on 2 622 receivers.They did exactly as you describe at first then they finally quit all together.
 

MattG@DISH

SatelliteGuys Pro
Dec 30, 2010
3,871
230
Denver, Colorado
I am sorry if you did not understand what I was trying to say. I will try again. The receiver is not "remembering" it is connected via the HDMI cable. I have to "remind" it by cycling to the HDMI input again from the TV. Once the TV sends the input source to the receiver, it connects and I get a picture. Every other Dish receiver I have connected to my other TVs "remembers" automatically, without me having to reset the input source.

It's been doing this ever since you got the new TV, right? Was your last TV connected with HDMI? Could be a handshake issue between the receiver and new TV. Will you send me a PM with your phone number or account number?
 

delanewf

Thread Starter
SatelliteGuys Family
Jan 20, 2005
60
0
No, I just got the vip612 yesterday. The new TV had been the second TV on a vip622 so it was not connected via HDMI to anything. I do believe there is a handshake problem between the TV and the receiver. The TV had no problem handshaking with my PS3 through the HDMI but the 612 is definitely having a problem.

If the TV has no problem communicating through HDMI with other devices but can't do it with my receiver, isn't the problem with the receiver?
 

MattG@DISH

SatelliteGuys Pro
Dec 30, 2010
3,871
230
Denver, Colorado
It would be a software issue with the receiver. If you send me your phone number or account number, receiver software version, and TV model number I'll put in a report for you
 

digiblur

SatelliteGuys Master
Jun 8, 2005
14,190
4
Louisiana
This is my problem: I have a brand new VIP612 hooked up to a Philips TV through HDMI. Every time I turn on the TV, no picture through the HDMI. I cycle through the TV's video sources back to the HDMI source the TV was originally on and the picture comes back. All other outputs(component, composite) work on the receiver and TV. None of the 3 HDMI inputs on the TV work with the receiver. I hooked up my PS3 to the TV's HDMI and when I turn on the TV, it shows the picture immediately. This tells me the HDMI inputs on the TV are fine. The problem has to be with the receiver.

For some reason, when I power down the TV, the receiver loses its connection to the TV. Once I turn on the TV and cycle to the same HDMI input, the picture comes back.

Does anyone know if there is a fix to this? Has anyone heard about this problem before? Is there any menu options that need to be turned on or adjusted on the receiver?

Thanks in advance.

I had to do this with my 722k and 722 hooked up through an HDMI switch to a Sharp LCD. I would turn things on and no video. So I would cycle the hdmi swith over to another input then back. I haven't had to do this with the DirecTV receiver.
 

dare2be

SatelliteGuys God
Lifetime Supporter
Jul 15, 2011
12,684
7,575
FL
2 possibilities come to my mind...first, already mentioned, the 612 HDMI port going bad. I believe that has been reported as a known problem in the past?

2nd, the TV does not maintain the HDMI handshake when powered off, which again, I remember some reporting this problem as well, and a firmware upgrade to the TV fixed it.
 

MattG@DISH

SatelliteGuys Pro
Dec 30, 2010
3,871
230
Denver, Colorado
BTW, did you PM MattG?

Yes, they did

2 possibilities come to my mind...first, already mentioned, the 612 HDMI port going bad. I believe that has been reported as a known problem in the past?

2nd, the TV does not maintain the HDMI handshake when powered off, which again, I remember some reporting this problem as well, and a firmware upgrade to the TV fixed it.

I didn't think of a possible firmware update on the TV, but will mention it to the OP in a PM
 
Top