HR-54 Keeps Repeating Purple Screen Reboot Sequence

chasfh

chasfh

Thread Starter
Active SatelliteGuys Member
Original poster
Feb 25, 2006
22
3
I have had my HR-54 for a few years now, nary a problem with it.

Just yesterday, I pressed the red button on the side to reboot. It shows me three purple screens: First it says, “Hello Your DirecTV receiver is starting up”; then “Almost there, a few more seconds please” while showing a progress bar; then “Just a few more seconds...”, which lasts about one to two minutes; then it starts over again. This repeats interminably.

First time this happened, I unplugged the power from the box and let it sit for a couple minutes, then plugged it back in, and it worked fine. After that, nothing has helped. Not the red button, not unplugging the cord from the box, not unplugging the power from the wall, not letting the box sit without power overnight—nothing. The same purple screen sequence just keeps repeating.

In a similar thread where someone posted a similar problem, a reply suggested pressing “Select” to interrupt the sequence and follow the prompts for a BIST self-test. That doesn’t work here. Nothing I have tried interrupts it so far.

Does anyone recognize this and have any suggestions?
 
larry55

larry55

SatelliteGuys Pro
Pub Member / Supporter
Jan 15, 2009
1,216
128
dothan al
I has the same problem with my hr54- 500 . Direc replaced the receiver.
 
chasfh

chasfh

Thread Starter
Active SatelliteGuys Member
Original poster
Feb 25, 2006
22
3
I see. So, nothing else to do. Damn it.

Thanks.
 
Juan

Juan

Supporting Founder
Supporting Founder
Sep 14, 2003
29,965
7,618
Moscow Russia
It would break the loop cycle...worth a shot

Sent from my SM-G950U using Tapatalk
 
Jimbo

Jimbo

SatelliteGuys Master
Lifetime Supporter
Jul 14, 2005
67,013
5,858
NW Ohio - Buckeye Country
It would break the loop cycle...worth a shot

Sent from my SM-G950U using Tapatalk
At that point, anything is worth a shot ...
I think they need to call D* and see what they say ... I'm sure they will run thru all the tests again, but this way they know whats going on.
They should be able to send them a replacement in a day or two.
 
Jillian2

Jillian2

SatelliteGuys Family
Jun 8, 2015
104
49
USA
I have had my HR-54 for a few years now, nary a problem with it.

Just yesterday, I pressed the red button on the side to reboot. It shows me three purple screens: First it says, “Hello Your DirecTV receiver is starting up”; then “Almost there, a few more seconds please” while showing a progress bar; then “Just a few more seconds...”, which lasts about one to two minutes; then it starts over again. This repeats interminably.

First time this happened, I unplugged the power from the box and let it sit for a couple minutes, then plugged it back in, and it worked fine. After that, nothing has helped. Not the red button, not unplugging the cord from the box, not unplugging the power from the wall, not letting the box sit without power overnight—nothing. The same purple screen sequence just keeps repeating.

In a similar thread where someone posted a similar problem, a reply suggested pressing “Select” to interrupt the sequence and follow the prompts for a BIST self-test. That doesn’t work here. Nothing I have tried interrupts it so far.

Does anyone recognize this and have any suggestions?


Yes, I had that problem and called tech support. Said it was not receiving a signal and had to be replaced. They brought me another receiver.
 
  • Like
Reactions: Jimbo

Similar threads

J
Replies
49
Views
2K
Jimbo
Jimbo
mini1
Replies
12
Views
806
John2021
John2021
B
Replies
3
Views
1K
ejb1980
E
C
Replies
70
Views
5K
Jimbo
Jimbo
dodger72
Replies
5
Views
653
texasbrit
T

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Who Read This Thread (Total Members: 1)

  • chasfh
Top