IE8 with Windows 7 (1 Viewer)

Status

skierrob

Thread Starter
SatelliteGuys Pro
Sep 4, 2004
226
4
I am noticing a strange issue with Satelliteguys.us with Windows 7 and Internet Explorer 8 on multiple computers including my home desktop, work desktop, work laptop and my media center desktop system. This has been going on for at least 2 months.

In all cases, when you visit the forums on satelliteguys.us, each page you load is extremely slow to display. I am not sure if it is one of the advertisements loading (and preventing the rest of the page from displaying) or what.

If I switch to Firefox 3 on any of these systems, the page loads "normally" and very fast.

Anyone else have any issues with Windows 7 and IE 8?
 

SatinKzo

Supporting Founder
Supporting Founder
May 22, 2004
6,232
83
Louisiana
No problems here with IE8 on win 7. I actually think it's about the same performance at firefox for me.

On my old XP box running IE8, firefox is markedly faster.
 

DodgerKing

SatelliteGuys Master
Nov 14, 2007
16,776
26
SoCal
That is why I have not used IE in years. Since FF came out, that is all I use (except for the rare occasion when I have to use IE on MS sites in order to download something)
 

Frank Jr.

Beati pacifici 5:9
Supporting Founder
Apr 8, 2004
13,389
1,850
Columbia S.C.
I have W7 and IE8 on this pc. Works well. I am real curious. What internet security are you using and what settings do you have under developer tools?
 
Status

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top