Logitech Harmony (Ultra I think with hub) & Internet problems..(Netgear AP Isolation possibly??) (1 Viewer)

StanDarsh

Thread Starter
SatelliteGuys Pro
Pub Member / Supporter
Jan 10, 2015
235
80
Georgia and such
Decided to get the harmony hub and remote. Great purchase..I like the harmony and how it works..but one issue that I had, and it's a major one...

I have the Netgear R9000. That model is the Nighthawk series (I think the production model actually has fans in it, although mine does not have fans, and the antennas are pretty floppy)...

I received the hub/remote and began set-up. Everything seemed to be connecting properly..until the harmony hub attempted to connect to internet. I'm not sure what the Netgear router is doing as far as AP Isolation -- which used to be a setting in Netgear if I remember right..but is no longer there...however..
When I attempted to connect the Harmony to the SSID of the Netgear R9000...I got a successful connection...but no internet. Was the internet down at that time? no...internet was working great.
So..I battled with this for over an hour...connected to the SSID...disconnected. Reboot the router. Factory reset the router. All my other devices are working fine and have internet...but the harmony couldn't get internet at all...no matter what I did.

So..I decided to try and use the spare router that I set-up to use on my Ubuntu box...which is running PopcornOS. I took an old Linksys E2500 and put AdvancedTomato on it...and I use that on my PopcornOS (Ubuntu) rig..along with my VPN..

Soon as I connected the Harmony to the SSID of the E2500...boom..internet on the Harmony Hub worked great. Downloaded an update right away..and began the initial set-up as it should. Finished the set-up of devices and decided to try and use the R9000 SSID again..since the Hub was completely set-up and ready to be used. So I changed the wifi info to point to the R9000 SSID...and there was that error again..the Hub couldn't connect to internet.

At this point...I don't mind putting AdvancedTomato on the R9000 (altho I'm not sure it's compatible since I haven't delved into checking it)...but apparently the default Netgear firmware does some sort of AP Isolation thing...
I tried putting the Harmony Hub in the DMZ according to the attached devices and what the IP was shown to be..that didn't work.
I tried changing the settings as follows:
Enabled Implicit BEAMFORMING - enabled/disabled ----->no change in error.
Enable MU-MIMO - enabled/disabled ---->no change in error.
Enable 160MHZ bandwidth in 5ghz - just for gigles enabled/disabled even tho hub uses 2.4ghz ---->No change in error.
Enable Smart Roaming - enabled/disabled --->no change in error. This setting apparently deals with using a repeater, which I do use, the EX8000 is connected to the R9000 as a repeater...but I didn't mess with this much other than trying the Harmony.

so after all that...none of that could make a difference. I had to revert back to using the SSID of the E2500...and when I tried to set-up my 4K Roku Premiere+...it wouldn't detect it, since it was on the R9000 SSID. I had to move the Roku over to the E2500 SSID just so I could still use my Roku and have the harmony able to control it.


Does anyone have any ideas on this?
 

Cheddar_Head

SatelliteGuys Pro
Feb 13, 2008
582
739
Colorado Springs
Do you have MAC address filtering turned on? If so you will need to enable the MAC address of your hub for internet access.

No idea how to do this on your Nighthawk.
 

StanDarsh

Thread Starter
SatelliteGuys Pro
Pub Member / Supporter
Jan 10, 2015
235
80
Georgia and such
I don't have MAC filtering. I don't have any sort of weird IP stuff...except a static IP to my PS4 according to it's MAC.
 

arlo

SatelliteGuys Pro
Dec 4, 2016
445
192
North Eastern
Netgear firmware can act a little funky. That's why I like DD-WRT, Merlin firmware for my Asus.
All of my home devices are set to fixed I.P. by MAC in the router. Makes browsing my HTPC and laptops a sure thing. Don't really know off the bat how to help you but my Ultimate and hub work good on my LAN.
 

StanDarsh

Thread Starter
SatelliteGuys Pro
Pub Member / Supporter
Jan 10, 2015
235
80
Georgia and such
I believe there is something with AP Isolation in Netgear routers that keeps the Hub from doing what it needs...I can definitely fix this in my AdvancedTomato router, but my stock Netgear R9000 has problems with the harmony...
Even though the AdvancedTomato router connects to the Netgear R9000 (via a managed Ubiquiti switch)...
 

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top