multiswitch problem?

Status
Please reply by conversation.
T

twek

Thread Starter
New Member
Aug 29, 2005
1
0
i just moved and reinstalled my satellite dish. I accidently dropped the dish while hooking it up. that said, I do have a signal on all three sattelites. However I only two of the four outputs from the dish work. The other seem to be dead. I have tried using different cables and receivers. Any suggestions would be helpfull.

Oh, it is a Phase III dish.

Thanks
 
silversurfer

silversurfer

Supporting Founder
Supporting Founder
Sep 8, 2003
1,147
1
Las Vegas, Nevada
Welcome to SatelliteGuys! Your cheapest option is to replace the dish. I recommend Valueelectronics for a replacement source. If you don't want to go that route you could use a seperate multi-switch but it would cost quite a bit more. If you choose that route ensure you get a cascadable multi-switch. Good luck....
 
boba

boba

SatelliteGuys Master
Dec 12, 2003
11,350
1,033
Dorchester, TX.
silversurfer said:
Welcome to SatelliteGuys! Your cheapest option is to replace the dish. I recommend Valueelectronics for a replacement source. If you don't want to go that route you could use a seperate multi-switch but it would cost quite a bit more. If you choose that route ensure you get a cascadable multi-switch. Good luck....
A replacement multiswitch wouldn't work you would need all 4 outputs working to connect another multiswitch. Replace the Dish or the three LNBs cost is about the same. :)
 
Status
Please reply by conversation.

Similar threads

U
Replies
2
Views
1K
dgordo
D
S
Replies
1
Views
1K
HCI
J
Replies
3
Views
947
techdood
techdood
G
Replies
2
Views
2K
Gus_Smedstad
G
S
Replies
5
Views
2K
B
Top