Need North America Satellite .bin file for Satlink WS-6906

Yeah the Super SSU Convertor.exe within the CTK DB Tool folder. Try that. If you succeed send me both file versions please.
Try unplugging the FTDI cable. Then while showing hidden devices, delete every com port there is.
Shut down and cold boot your pc. Don't just restart it. Then turn it back on. Let it settle down and open Dev Mgr., show hidden devices. Any com ports?
Plug in your FTDI cable. What populates? Port number? Can it be manually changed to something usable?
How about in the meter itself. In the menu can you assign a port number (You may have already axed me that)?
Nothing in the menu for assigning com ports. But wait! Progress !!

.....axed. lol
The Com Name Arbitrator Tool is linked below also. Some other cool tools for a rainy day.
Sorry you're having issues but for the FTDI at the very least manually assigning ports should work.
Did you check under all USB related items with show hidden devices enabled for any instances that may have in the past taken over the ports you need?
Hint. If you get a 3, com 4...device sucking up the slot you need. Why not try bumping them up to a higher port number.
There also is a method in dev. mgr. to show non-present devices such as USB flash sticks, cameras, CF cards, external HDD's that aren't plugged in....but were at some time. Google search for it. Requires that you open a command prompt as adminintrator, copy and paste or type in a line of code. It's non-destructive 100%. If you wipe USB stuff, the next time you plug them in. They will work ok just as before. We need to get you the com ports you need.
I'm of the belief from the manual in the database editor folder that you must 100% match the header file and other specifics to be able to write a foreign, someone else's file into the finder. Because of clones?? I dunno.
Were there even clones back in the '40's when it was made?
Progress?? Maybe not.. After trying different methods I was able to get a USB port recognized as com3. I did this by choosing "uninstall device" to all the USB drives in the device manager.. Then no USB's would show up, even if you searched for hardware changes or cold booted.. I plugged my adapter in a front USB port and one would show up, not the right com# though. Repeat step one.. Eventually, after a few tries, com3 was assigned,

But.. when I try to connect, instead stating that com*.* is being used/not available as before, it does try to connect, but times out. I have tried a straight through cable and a nulled cable, powering up after it starts to connect (the method used when loading a .bin file to this finder), with no success. The program even reacts the same way when the cable is unplugged from the finder. Maybe a setting somewhere?

Screenshot 2023-06-03 231840.jpg
Screenshot 2023-06-03 232824.jpg

Having the original .bin file from yours would be a nice thing to have. Send it!

I don't have the original .bin file.. I wish I did. That is the reason for this thread.

I do have 8 or nine .bin files with foreign satellites. I have one bin file that I dumped from my finder with only one satellite entered, G19, it has no transponders entered.

I call uncle.. I'm now convinced this finder is a sinking ship.

I'm picking this newer one (GTMedia Model V73HD) up in the morning .. Not the latest or greatest but an upgrade . I did some searches and there is newish software available for this model, unlike the WS-6906.

If you want a newer model (Pro or Max) from this company (GTMedia), you have to order and wait weeks for it to come from China, and you know how that sometimes goes.

Screenshot 2023-06-03 235723.jpg
s-l1600 (1).jpg

I would like to figure it out though.. I saw mentions of the CTK DB Tool used with a newer 6908 model, but not the 6906.
Last edited:
Regular rs232. no xover cable. in dev. mgr try different baud rates and the fifo settings. read what they do. your pc is a lot faster than the finder. slow it all down using fifo settings but change only the baud rate. 9600, 19200...
btw. i prefer a receiver actual with a monitor and 12v battery. those damned finders have issues like the battery crapping out when you least expect it. plus. a receiver wont so much set in a drawer unused. yeah.

do have 8 or nine .bin files with foreign satellites. I have "one bin file that I dumped from my finder with only one satellite entered", G19, it has no transponders entered.
send it by breakfast and before beer-thirty
I picked up the new finder and found out some things. Instead of using an external program with a cable, connected to a com port for backup/upgrade as with the 6906, this uses a USB thumb drive.

I inserted a thumb drive into the new V73HD and made a backup. It downloaded a file "V8Finder_Meter,udf" , 1600K bits, which I assume is all the satellite lists, which btw has every region on the planet. I don't know how old the list is. Maybe if I dig around a little bit in the menu, I can find out.

I was able to view the .udf file with an online program. My backup is only the region I chose during set up, which is North America.

The 6906 upgrade.exe software will not work with the V73HD. It cannot connect... and of course, for the heck of it, I tried CTK DB Tool which would not connect either.


A little old, but not too old. I can always edit if I need to.

Last edited:
Here it is.
Thanks. Dead in the water, couldn't get anything out of it.
Look in the transfer.ini file in the db program folder. Open it. There's the com port settings. I guess you could have changed it to something workable. But your baud rate needs to be 115200, You could have edited it to com-whatever.
Just one last try maybe to grab the data from it? Good that you got the new unit.