Osmio 4K Clock Problem (1 Viewer)

Register Today to see less ads! It's Free!

johnnynobody

Star Trek fan
Aug 2, 2009
6,735
1,236
USA
Far better than NTP time. It might be off around 5 seconds, but it beats it suddenly going to something random, at a year or months earlier.

EB over at Legit says it's an on-going issue with the NTP time software originally built into Enigma images. He claims that it'll be fixed for once and all in TNAP 4.1, which is a few weeks off.
One of my receivers is sometimes off by 2 minutes. Rebooting corrects it. But I have noticed that both receivers have minor differences in time between them most of the time. I'll be glad when they get the NTP time issue resolved.
 
Register Today to see less ads! It's Free!

arlo

SatelliteGuys Pro
Dec 4, 2016
588
313
North Eastern
......osmio 4k. openatv 6.3 & 6.4 in 2 slots.
tp or ntp time....perfect always.
el bandido is a great dude. but if tnap were so good i'd be using it right now.
just saying.
 

johnnynobody

Star Trek fan
Aug 2, 2009
6,735
1,236
USA
The bad thing about using AFN for time sync is that when I stop watching a program the dish moves over to 99W. I suppose that doesn't happen if the receiver is on all the time. But I don't want my receiver on all the time. Any news of a NTP time sync fix yet?
 

primestar31

SatelliteGuys Master
Lifetime Supporter
Mar 15, 2005
9,852
6,438
Beta Omicron Delta III
Any news of a NTP time sync fix yet?
No, though he has posted some TNAP 4.1 test images if you want to try them.
The bad thing about using AFN for time sync is that when I stop watching a program the dish moves over to 99W.
That's far better than it randomly going back to some years in the past, so timers don't fire at all.
 

primestar31

SatelliteGuys Master
Lifetime Supporter
Mar 15, 2005
9,852
6,438
Beta Omicron Delta III
It would cost a lot more to replace the actuator than to reset the time or to have the time set via NTP. I'm going back to NTP and hope for the best.
IF it starts going random time again while using Standby mode, then try a test of leaving the receiver ON all the time, and see if it holds NTP time then. Let us know.
 

cyberham

SatelliteGuys Pro
Jun 16, 2010
3,674
1,695
Nova Scotia
I installed the TNAP 4.1 test image today. I have switched my Mio+ to standby to see if it keeps accurate time. So far it's good.

Sent from my SM-G950W using Tapatalk
The time quickly went wrong when I switched off the receiver. So I reconfigured the receiver to only use Internet for a reference instead of Internet/transponder. The receiver is keeping good time while switched on. But I'll turn it off overnight and see how it does.

Sent from my SM-G950W using Tapatalk
 
  • Like
Reactions: primestar31

johnnynobody

Star Trek fan
Aug 2, 2009
6,735
1,236
USA
IF it starts going random time again while using Standby mode, then try a test of leaving the receiver ON all the time, and see if it holds NTP time then. Let us know.
I installed 4.1 on one of my mios but there isn't an option for "System time" anymore. In other words, there's no way to sync the time. There was a plugin for systemtime but the box wouldn't let me install it - error message was that there was already a systemtime plugin installed. I couldn't find that systemtime plugin so I wasn't able to remove it.
 

primestar31

SatelliteGuys Master
Lifetime Supporter
Mar 15, 2005
9,852
6,438
Beta Omicron Delta III
I installed 4.1 on one of my mios but there isn't an option for "System time" anymore. In other words, there's no way to sync the time. There was a plugin for systemtime but the box wouldn't let me install it - error message was that there was already a systemtime plugin installed. I couldn't find that systemtime plugin so I wasn't able to remove it.
cyberham If that's true, then how is Cyberham using it, because he also installed it, and said he changed his clock settings...

Also, you DID read that I said those TNAP 4.1 were test images, correct?
 

cyberham

SatelliteGuys Pro
Jun 16, 2010
3,674
1,695
Nova Scotia
There is no longer a System Time menu. In Setup>System>Customize, there is a Time synchronization method parameter where you can choose Auto, Transponder Time or Internet (NTP). You can also set the NTP hostname. So if the time goes wrong, you must restart the receiver to get a time update.

Latest here is the clock went wrong again. When I turned on the receiver, the date was December 31, 1969. So for now, I am going to leave the receiver turned on continuously.
 

johnnynobody

Star Trek fan
Aug 2, 2009
6,735
1,236
USA
There is no longer a System Time menu. In Setup>System>Customize, there is a Time synchronization method parameter where you can choose Auto, Transponder Time or Internet (NTP). You can also set the NTP hostname. So if the time goes wrong, you must restart the receiver to get a time update.

Latest here is the clock went wrong again. When I turned on the receiver, the date was December 31, 1969. So for now, I am going to leave the receiver turned on continuously.
Doesn't exist on my box.
 

Attachments

  • customizemenu.jpg
    customizemenu.jpg
    157.9 KB · Views: 28

primestar31

SatelliteGuys Master
Lifetime Supporter
Mar 15, 2005
9,852
6,438
Beta Omicron Delta III
There is no longer a System Time menu. In Setup>System>Customize, there is a Time synchronization method parameter where you can choose Auto, Transponder Time or Internet (NTP). You can also set the NTP hostname. So if the time goes wrong, you must restart the receiver to get a time update.

Latest here is the clock went wrong again. When I turned on the receiver, the date was December 31, 1969. So for now, I am going to leave the receiver turned on continuously.
cyberham Can you give us a screenshot of that page, so we can see the settings?
 

arlo

SatelliteGuys Pro
Dec 4, 2016
588
313
North Eastern
Let's clarify something. I read some are turning the receiver off cold. Not on standby. I don't use TNAP. But....
El Bandido over on Legit has stated the real time clock (RTC) has no battery backup. Or super capacitor if that be the case.
So. If you divorce the receiver from power, it has to lose set time/date. On standby it shouldn't.
It's not an image thing. It is the design of the electronics in the receiver. No provision for or a not installed RTC power source. The image I use will lose time and date if left off over night. On standby it doesn't. And fyi I always use ntp and not tp as the time source.
Looking into problems of using ntp you may want to delve into your router setting too. That would be up to your particular router or firmware. Some have issues with allowing udp port 123 (ntp) traffic. Might be worth looking into.
 
Register Today to see less ads! It's Free!

Jim S.

When someone asks you if you're a god, you say yes
Lifetime Supporter
Jan 2, 2006
5,338
777
FN11od
......osmio 4k. openatv 6.3 & 6.4 in 2 slots.
tp or ntp time....perfect always.
el bandido is a great dude. but if tnap were so good i'd be using it right now.
just saying.
I went with PurE2 6.5, because I liked the clean, responsive default skin and the built-in options to set up many different types of network shares. So far the time hasn't bugged out and the wifi has stayed up. (I can't prove that my wifi issue isn't a hardware issue, but it seems terribly suspicious that it's only gone out with one software family yet.) The only thing I miss from TNAP is the mapping of the blind scan to the blue button and the channel selection to the green button, but I'm assuming they can be changed, I just haven't had time to look into it yet.
 

cyberham

SatelliteGuys Pro
Jun 16, 2010
3,674
1,695
Nova Scotia
El Bandido has explained you must edit your Settings file to remove any old references to SystemTime. See his comment on legitfta. One user has tried and it has solved the time accuracy issue. I have these old references in my Settings file so I will edit and try the clock again.

Too busy right now with the Olympics closing ceremony about to begin.
 
Last edited:

primestar31

SatelliteGuys Master
Lifetime Supporter
Mar 15, 2005
9,852
6,438
Beta Omicron Delta III
Let's clarify something. I read some are turning the receiver off cold. Not on standby. I don't use TNAP. But....
El Bandido over on Legit has stated the real time clock (RTC) has no battery backup. Or super capacitor if that be the case.
So. If you divorce the receiver from power, it has to lose set time/date. On standby it shouldn't.
It's not an image thing. It is the design of the electronics in the receiver. No provision for or a not installed RTC power source. The image I use will lose time and date if left off over night. On standby it doesn't. And fyi I always use ntp and not tp as the time source.
Looking into problems of using ntp you may want to delve into your router setting too. That would be up to your particular router or firmware. Some have issues with allowing udp port 123 (ntp) traffic. Might be worth looking into.
I keep my Mio in Standby when not in use. NEVER shut it off, and when set to NTP time, it does NOT keep time anymore. The front screen is in my full view while sitting on my living room chair, and I can SEE the clock suddenly wander off to some random time, whenever it pleases. I finally gave up on NTP time, and changed to transponder time and use Bar's & Tone on 99w as a Startup service. That's slow by about 4 seconds, but NEVER varies to random times and dates like NTP does.

My router is fine. The Mio USE to work perfect for well over a year +, at least with the original TNAP. Then came the updates, and it started going bad.
 
Register Today to see less ads! It's Free!

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top