Rv Surround and Bell PVR (1 Viewer)

Register Today to see less ads! It's Free!

DCinBC

Well-Known SatelliteGuys Member
Dec 30, 2007
28
0
Hi,

I have a Bell PVR ( 5900). In our RV, it came with a surround sound system ..... not exactly state of the art, but its kinda nice. The problem is that now that we are on Satellite and put the audio from our PVR to it, you have to crank it way up to max to hear it a bit. It plays the DVD's fine still (it came on our 2004 RV model). The Household Brand name is the Executive 9000 ... can't find much on the web to help me. I am thinking that the inputs were for an external VCR and the feed is somewhat different.


Any ideas?

Thanks,
 
Register Today to see less ads! It's Free!

DCinBC

Well-Known SatelliteGuys Member
Dec 30, 2007
28
0
There is only one input set on the system: red yellow and white RCA. The yellow (video) says VCR input.

I am using the output 1 on the back of the Bell.....

?

Thanks,
 
Register Today to see less ads! It's Free!

navychop

Member of the Month - July 2014!
Pub Member / Supporter
Lifetime Supporter
Jul 20, 2005
52,298
17,272
Northern VA
How is your DVD player set up? This sounds exactly like a problem I had with my PS3 plugged into my RV "sound system."

Sound was very low. HDTV was fed with HDMI, "sound system" with RCA cables. I had forgotten to tell the PS3 to output sound via the "multi-AV" connector, rather than the HDMI. When I corrected that, sound was at normal levels.

Hope this gives you some ideas to help.
 
Register Today to see less ads! It's Free!

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top