staying logged in

mitchflorida

SatelliteGuys Pro
Oct 12, 2004
972
93
I am also having trouble staying logged on with Internet Explorer.


Never had any trouble until the last week or so. It is a bit of a hassle.


I erased all of my satelliteguys.us cookies and it didn't fix the problem.


What next?
 

Hall

SatelliteGuys Master
Feb 14, 2004
18,409
3,194
Germantown OH
Are others still having this issue or have people just given up and live with it ?? I STILL am not logged in when I visit http://satelliteguys.us/. If I click "Forums", I am logged in and going back to the front-page, I remain logged in. If I login at the front-page instead, I still get the "Welcome.... you'll be re-directed" message, get sent back to the front-page, and guess what ?? I'm not logged in.

I have deleted every cookie with "satelliteguys" in it a dozen or more times. I'm using Firefox 1.5.
 

Hall

SatelliteGuys Master
Feb 14, 2004
18,409
3,194
Germantown OH
Interesting. Immediately after submitting that post, I went back to my personal home page (customized Google page). I typed "http://satelliteguys.us/" in and one can guess what happened. No, I wasn't logged in..... I then typed "http://www.satelliteguys.com/" and I was logged in.
I think there's a problem with the cookie that this website sends or maybe it's the re-direct page that's at fault. Do links on this site use the full URL or are the link relative, i.e. the link for "Forums" should be just "index.php" vs "http://www.satelliteguys.us/index.php". Also, what URL does the re-direct page use, "index.html" or "http://www.satelliteguys.us/index.html" ??
 

damaged

SatelliteGuys Pro
Jun 22, 2005
2,605
1
South of Heaven
Scott Greczkowski said:
Do not use http;//satelliteguys.us use http;//www.satelliteguys.us instead. ;)
mod_rewrite is your friend. :)

RewriteEngine on
RewriteCond %{HTTP_HOST} !^satelliteguys\.us [NC]
RewriteCond %{HTTP_HOST} !^$
RewriteRule ^/(.*) http://www\.satelliteguys\.us/$1 [L,R]
 
Last edited:

Hall

SatelliteGuys Master
Feb 14, 2004
18,409
3,194
Germantown OH
Scott Greczkowski said:
Do not use http;//satelliteguys.us use http;//www.satelliteguys.us instead. ;)
The "www" should NOT be necessary. Some would say that's a misconfigured webserver... :rolleyes:
Did you forget that the name of your site is "satelliteguys.us" and not "www.satelliteguys.us" ?? I'll use the www version as soon as you change all of your graphics and all references to satelliteguys.us. :D
 

Anole

SatelliteGuys Master
Sep 22, 2005
11,819
9
L.A., Calif.
enough already

Scott Greczkowski said:
Do not use http;//satelliteguys.us use http;//www.satelliteguys.us instead.
hall said:
The "www" should NOT be necessary. Some would say that's a misconfigured webserver... :rolleyes:
Yes, but if this is a solution, then I think people should take the suggestion and quiet down.
I also have a forum, and we managed to get it to work both ways, but it's hardly a deal-breaker.
Let's close this thread and be done with it. ;)
 

damaged

SatelliteGuys Pro
Jun 22, 2005
2,605
1
South of Heaven
If he inserts that stuff I posted above into httpd.conf, it would have been a absolute, elegant solution (there are OTHER ways, but this is easiest to deploy, especially since I do not know the server setup, or customizations (if any)).
 

damaged

SatelliteGuys Pro
Jun 22, 2005
2,605
1
South of Heaven
LER, could you let me know the issue(bug), or if it was related to the config code I gave or not, I would like to make sure I do not continue to suggest that if there could be issues, without having a 'fix'. Thanks.
 

LER

Supporter / Pub Member / Server Weenie
Sep 28, 2003
7,055
30
Round Rock, TX US
the First RewriteCond line does NOT need the (!) before the ^satelliteguys\.us$ Regular expression. since ! means NOT.

LER
 

damaged

SatelliteGuys Pro
Jun 22, 2005
2,605
1
South of Heaven
Doh, on some configs (keeping in mind I know little to none of yours) the ! is required, (and I knew what ! meant ;)), oh well, glad it worked out, now to see if it fixed their issues.
 

LER

Supporter / Pub Member / Server Weenie
Sep 28, 2003
7,055
30
Round Rock, TX US
ours is VERY simple (modulo the number of serveralias lines :) )

It's working now, and we'll see what happens.

LER
 

Hall

SatelliteGuys Master
Feb 14, 2004
18,409
3,194
Germantown OH
I just typed 'satelliteguy.us' as the URL and it was rewritten to prefix 'www' to the front. Should be no more cookies for just satelliteguys.us now, right ??
 

LER

Supporter / Pub Member / Server Weenie
Sep 28, 2003
7,055
30
Round Rock, TX US
hall said:
I just typed 'satelliteguy.us' as the URL and it was rewritten to prefix 'www' to the front. Should be no more cookies for just satelliteguys.us now, right ??
Correct. Please do let us know if anything breaks.

LER
 

Users Who Are Viewing This Thread (Total: 1, Members: 0, Guests: 1)

Top