DDNS Question

jimdandyvi

SatelliteGuys Pro
Jun 19, 2010
496
0
Virgin Islands
DDNS provides you with the equivalent of a static public IP address to facilitate you or other individuals to access resources on your network. It is useful for viewing security cameras or if you are running a web site on your home network.

Just remember if you set your network from the outside you have made it much easier to hack your network and gain access to your files. Set strong passwords to access shared files. In this day and age I would not make any drives available that have sensitive information on them. If you want to share photos fine if you don't care if someone draws mustaches on your friends and families photos.

Most people set up a VPN to further secure their connection when they are accessing shared network files on the Internet.
 

stimpson

Miller Lite Tester
Oct 2, 2006
4,701
46
Benton, Arkansas
Ok heres a follow up. I may need to start a new thread on this one, but we'll see. I got my router DDNS set up through DYN.org and now the ASUS AiCloud app functions outside my network. For what ever reason the free ASUS dns did not work. Should have used DYN.org in the first place because that's where I already have my security cams DVR and a single IP camera set up. Here's the issue I can access the security cameras DVR and the IP camera via the web with the host names I have set up for them just fine. When I try to access the router from the web with its host name, it goes to the security cams DVR. I then deleted the router host name, then created a new one at DNS.org, set up the router with the new one, and it still goes to the DVR. I even deleted the DVR host name from my DYN.org account, tried the router address again, same thing. I then disabled the DNS function on the DVR, tried the router address again, same thing. It still goes to the DVR. I have rechecked my port forwarding overe and over. I have not duplicated any ports between devices. Any ideas?
 

Scott Greczkowski

Welcome HOME to SatelliteGuys!
Staff member
HERE TO HELP YOU!
Sep 7, 2003
100,217
18,834
Newington, CT
Hard to answer your question since everyones setup is different.

But here is what mine looks like for the port forwarding.
 

Attachments

  • router.jpg
    router.jpg
    89.7 KB · Views: 69

harshness

SatelliteGuys Master
May 5, 2007
16,882
2,923
Salem, OR
You've probably forwarded all HTTP (port 80) and/or HTTPS (port 443) traffic to the DVR. You need to have the router respond to HTTP requests on a different port number.

For example, you could set the router up for port 456 (Port of Web Access from WAN in the Administration->System tab) and log into it with http://stimpsoncameras.dyndns.org:456.

As I said previously, it is pointless to have a bunch of URLs that all point to your router. Because they ALL share the router's Internet IP address, it becomes a matter of setting the router up to forward that IP address to different port numbers based on what you want to do. You'll find this table in the "Virtual Server/Port Forwarding" tab in the WAN Advanced Settings. Chances are pretty good that there are already entries in there for your camera(s).

I'm set up to access a number of computers VNC servers and my Slingbox Solo through my DynDNS address and I use Port Forwarding to do this.
 

harshness

SatelliteGuys Master
May 5, 2007
16,882
2,923
Salem, OR
You've port forwarded port 80 to Defender2 so that's why you can't access the router interface from the Internet (WAN) with a regular HTTP call. You need to set up the router to respond to port 8080 (this may actually be the default) or change the Defender2 forwarding port. Try http://myasusrouter.dyndns.org:8080 from outside the LAN and see what you get.

Note that the forwarded port number does NOT need to be the same as the port number on the destination. Defender1 could have been set up as port 9000 on the WAN but forwarded to port 80 on the LAN. I find it a lot less trouble to do port number translation in the router as you only have to configure one device to shift everything around. I have three home computers set up for VNC and they all listen on the default port 5900 but I access them from the Internet independently by using port forwards.
 

stimpson

Miller Lite Tester
Oct 2, 2006
4,701
46
Benton, Arkansas
You've port forwarded port 80 to Defender2 so that's why you can't access the router interface from the Internet (WAN) with a regular HTTP call. You need to set up the router to respond to port 8080 (this may actually be the default) or change the Defender2 forwarding port. Try http://myasusrouter.dyndns.org:8080 from outside the LAN and see what you get.

Note that the forwarded port number does NOT need to be the same as the port number on the destination. Defender1 could have been set up as port 9000 on the WAN but forwarded to port 80 on the LAN. I find it a lot less trouble to do port number translation in the router as you only have to configure one device to shift everything around. I have three home computers set up for VNC and they all listen on the default port 5900 but I access them from the Internet independently by using port forwards.

Ok. Adding the 8080 at the end of the address did the trick. Thanks for the help. That was driving me nuts!!!
 
Top