ECODA 22KHz switch "Leaks" (1 Viewer)

Status
Please reply by conversation.

RT-Cat

Thread Starter
"My person-well trained"
Pub Member / Supporter
May 30, 2011
1,657
224
Cold, Cold,Michigan USA
Picked up a couple of ECODA 22KHz switches. Did a temporary hookup with the SV 8000 to test the switches. SV connected to the 22KHz off side and PBS came in w/o any problem. Signal 64, Q 43. Turned 22 on and signal went to zero. OK switch works that way.

Shut down, changed connection to the 22 "on" side, powered up and, what, I had PBS? But 22 was "off". Was getting signal 30 and Q 6. Turned 22 "on" and signal went back to 64 & Q 43. This appears the switch "leaks" on the 22KHz "on" connection. Is this the way these switches work or do I have some low quality knock offs?

RT.
DSC02220[1].jpg
 

SatelliteAV

SatelliteGuys Master
Lifetime Supporter
Sep 3, 2004
6,486
183
Roseville, CA
22KHz switches need to have both inputs connected in order to work properly. 22KHz switches will not work correctly if only the 22KHz ON side is connected. What you are experiencing is normal with only one input connected.
 

SatelliteAV

SatelliteGuys Master
Lifetime Supporter
Sep 3, 2004
6,486
183
Roseville, CA
BTW.... we have a great deal on eBay for 2, 5 or 10 Ecoda switches with free shipping. :)

Bet you haven't seen Ecoda 2x1 switches at this low of price before.

Click on the link in the signature below.....
 

Corrado

SatelliteGuys Pro
Apr 2, 2007
2,380
270
Hudson Valley Region, NY
Interesting, I'm running several Ecodas myself and I guess I never tried only one port and never experienced it. Now I want to test it.

Nice deal on the switches, Brian. I think I'll pick up a couple more.
 
Status
Please reply by conversation.

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top