No longer able to access Tapatalk

dweber

SatelliteGuys Pro
Original poster
Pub Member / Supporter
Jul 29, 2005
1,790
2,582
Plain City, OH
I have been using Tapatalk to access SatelliteGuys. Since I started getting advertisements, I decided to pay $5.34 on November 25 to get VIP access to Tapatalk. My subscription to Tapatalk for $4.99 is active and renews on November 25, 2023. I kept receiving advertisements, so I decided to delete the Tapatalk app off of my Iphone 12 Pro Max and reinstall the Tapatalk app.
After reinstalling the Tapatalk app on my Iphone, I attempted to log in to Tapatalk using my email and password. Tapatalk claims that either my username, email address or password is not correct. I have also tried to log in to Tapatalk using Microsoft Edge and Google Chrome as browsers.
When I select "forgot password" and submit my email address, Tapatalk tells me it is sending a password reset to my email. However, I never receive an email with a password reset from tapatalk and I have tried this multiple times now for 3 days. I know my email is working because I am sending and receiving emails. So, I am frustrated since I really loved using Tapatalk to access SatelliteGuys.
I have sent an email to the Tapatalk support forum but have not heard anything. I am using my computer to send this. Any suggestions would be appreciated.

1669737740097.png
 
You will need to contact Tapatalk. The password reset is for them, not SatelliteGuys.

When you get it working stop paying them. I just started paying them for the site so you should not see ads in Tapatalk when browsing SatelliteGuys. (Note however you will see ads on other sites you browse using Tapatalk if they are not paying them to be commercial free.

I honestly thought Tapatalk was dead, was suprised to see them put out an update for our forum software, which they didn't do for way over a year.
 
Try to recover what email address tapatalk thinks you signed up with..maybe a typo or a gmail address
 
I don’t understand what has happened. When I would open the Tapatalk app on my phone it would not let me log in since it said my username, email, or password was not correct. When I tried to reset my Tapatalk password it claimed to email me a password reset but I would never receive the email.
Today I am at Honda waiting for my shattered fog light lens to be replaced. While waiting I decided to access SatelliteGuys using Safari on my cellphone. When the SatelliteGuys web site opened it asked me if I wanted to use Tapatalk. I said yes and it opened Tapatalk and logged me in.
So I am using Tapatalk to access SatelliteGuys. And no advertisements.
So I am baffled but pleased.


Sent from my iPhone using Tapatalk
 
Wow, today I started getting emails from Tapatalk for the password reset. I received an email at 9:03, 9:28, 9:29, 9:43, and 9:39.
So it looks like the Tapatalk mail server was offline and now it is sending out all of my password reset emails.
Of course Tapatalk is now working great. It logged me in using my SatelliteGuys credentials yesterday when Safari asked if I wanted to use Tapatalk to access SatelliteGuys.
I believe this happened because Scott paid to use the new Tapatalk plugin.
I always appreciate all the time and effort Scott puts in maintaining SatelliteGuys.


Sent from my iPhone using Tapatalk
 
I got a bunch of emails from Tapatalk this morning as well, including the one letting me know our Gold Points ran out on Thanksgiving Day which is why people were seeing ads then. II never knew that we were given Gold Points based on the amount people were posting from Tapatalk and I guess we built up a lot over the years.

Since we run out I am now paying the $10 a month which allows us to to turn off those ads for everyone visiting SatelliteGuys with Tapatalk.

I am happy they seem to be supporting Tapatalk again as they havent seemed to support it for over a year, even posts at their support forum were going unanswered.
 
Anyone else having trouble again with Tapatalk? Started yesterday, Receive an error stating: 'You are not logged in or you do not have permission to do this action'. Same results on two different iPads. Browser access is fine.
 

"Select For Moderation"

Voting feature?