PowerTech DG380 Problems (1 Viewer)

Status
Please reply by conversation.

Babadem

Thread Starter
SatelliteGuys Pro
May 21, 2007
2,293
160
MA
My DG380 has been acting crazy the past few days. First it wouldn't go East or West, then I rest it manually from the motor and also factory reset my Coolsat 5000. After all the reset, the motor worked fine for a while. Now, the motor can only go West. :mad: I have deleted limits, but the problem still persists. Anyone knows why this is happening and how to fix it?:confused:
 

pendragon

SatelliteGuys Pro
Oct 13, 2008
1,100
63
There are several likely possibilities, but this isn't comprehensive:

1. You haven't really reset the memory. I worked on a friend's DG-380 that had similar symptoms to yours. I had to get unusually aggressive with clearing the memory, but this was the problem.

2. One of the relays or its driver transistor is bad.

3. One of the hardware limit switches is bad.
 

Babadem

Thread Starter
SatelliteGuys Pro
May 21, 2007
2,293
160
MA
There are several likely possibilities, but this isn't comprehensive:

1. You haven't really reset the memory. I worked on a friend's DG-380 that had similar symptoms to yours. I had to get unusually aggressive with clearing the memory, but this was the problem.

2. One of the relays or its driver transistor is bad.

3. One of the hardware limit switches is bad.
So, how did you resolve the issue? Right now the situation is kind of changed a little bit. Let say I'm on 99.0°W for example and I move it to 2 degrees east or west.............nothing happens. But when I move the dish east or west by 4 or more degrees the dish motor moves. :confused:
 

Babadem

Thread Starter
SatelliteGuys Pro
May 21, 2007
2,293
160
MA
I just got a replacement motor from Sadoun, and will be hooking that up as soon as time permits.
 

turbosat

SatelliteGuys Master
Dec 26, 2006
9,001
75
Oneonta,AL
Your sig line says you had that 380 running a 1.2m dish....how long did it work before you started having troubles??
 

Babadem

Thread Starter
SatelliteGuys Pro
May 21, 2007
2,293
160
MA
Your sig line says you had that 380 running a 1.2m dish....how long did it work before you started having troubles??
It ran approximately 1yr and 9months. 6 months or so after i installed the motor, I used to have these issues once in a where the motors was not moving and I would always rest it and it would be good for a month or so, and happen again. But recently it stopped moving no matter what I did. That's not good, huh?
 
Last edited:

Jim S.

When someone asks you if you're a god, you say yes
Lifetime Supporter
Jan 2, 2006
5,257
695
FN11od
My DG-280 only lasted a year and a half before it would only go west (and would do so spontaneously too.) Bad relay. Rather than trying to find a substitute part (I couldn't find the exact part anywhere), I found that Sadoun was selling new boards for about half the price of a new motor (not that they even sell the 280 anymore...) I'm hoping that the new board lasts longer than the first one.
 
Status
Please reply by conversation.

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top