Azbox Power Supply (1 Viewer)

brentb636

SatelliteGuys Pro
Jun 24, 2006
4,278
6
5 miles N of Saugatuck, Mi
There was at least one bad batch of power supplies, and it looks like your vendor still has them. Hopefully, it's not another bad bunch. I had an Azbox Prem Plus for about 8 months without a problem. I bought a spare power supply when I bought the box, and other than switching it out to make sure it worked, never had a problem.
 

Lone Gunman

SatelliteGuys Pro
Pub Member / Supporter
Mar 19, 2010
3,065
756
southeast
Man, they had batch of bad PSupplies back about 2 years ago now wasn't it? Don't tell me there's more of them out there still?
 

pwrsurge

SatelliteGuys Pro
Pub Member / Supporter
Aug 7, 2007
919
30
Canada
We have just received a shipment of new replacement power supplies for the Premium HD Plus which should not have this issue anymore. These are from a different manufacturer and are both FCC approved and c (UL) us listed.


Regards,

PwrSurge
AzBox Canada
 

pro96

You Member, Member ?
Supporting Founder
Jul 18, 2005
6,459
11
OC
Never a prob on my old elite.

Sent from my SPH-D710 using Tapatalk
 

Valasante

SatelliteGuys Family
Oct 24, 2010
48
0
49n 2.2e
Help! Power supply needed for my Azbox Me.
I sent my faulty Azbox Me to the suppier(HD Satshop e.i in Cologne, Germany) for repairs. After two months and several promises, the machine was returned without the power supply. Having waited patiently with promises that it had been posted, but never came, they are now denying that they received it. Even though I have offered to pay for it, I am told that they don't have it. I have searched all over the internet without reply. I live in France but we don't have any suppliers. I have called Opensat in Portugal but no one picks the phone. I should be grateful if any one can help me.
 

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Latest posts

Top