Manhattan Skyline 1000 problems

R

ralphstirling

Thread Starter
New Member
Mar 28, 2014
1
0
AB
I am trying to help my in-laws get their Hope Channel satellite
system going again. The Manhattan Skyline 1000 receiver powers
up, says "Boot", then P004. I get no video output though, so can't
check menu settings. I've swapped video cables, so I think I've
ruled out the simple external possibilities.

Is failure of the video output common on these receivers? I've seen
mention of power supply failure on the forum, but the power supply
seems to be functioning or the led display on the front panel wouldn't
be working. The led display responds to remote control button presses
(dot blinks for each button press, and TV/Sat button changes display
to -tU-). I'm an EE, but 500 miles away from most of my tools, so
can't do any internal repairs.

If the receiver is toast, can I buy a new receiver and use the existing
dish and LNBF? I'm not a satellite user back home, so don't have
any personal experience.

Thanks,
-- Ralph
 
Wescopc

Wescopc

SatelliteGuys Pro
Pub Member / Supporter
Lifetime Supporter
Sep 11, 2005
1,891
200
Canby, Oregon
Sounds like it is toast - you can hook it up via coax (channel 3 or 4) or video RCA (yellow, red, white) cables. Try hooking it up with the cable set that you are not using just for kicks. Yes the dish and LNB can be used with a new receiver. However the new Glory Star receiver (HDVR 1200) only hooks up to the TV with RCA or HDMI cables, so if it is an old tv that can only use the rf of channels 3/4 - you would need a modulator to make it work.
Bob
 

Similar threads

RT-Cat
Replies
14
Views
2K
RT-Cat
RT-Cat
D
Replies
10
Views
1K
dbshelton
D
MosFET77
Replies
0
Views
810
MosFET77
MosFET77
G
Replies
3
Views
439
KE4EST
KE4EST
MosFET77
Replies
3
Views
497
MosFET77
MosFET77

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top