Edision Edision OS mio+ 4K HDMI issue

videojanitor

SatelliteGuys Pro
Original poster
Nov 3, 2008
257
55
I purchased an Edision OS mio+ 4K a couple of weeks ago and I like it -- but I've run into a couple of issues:

First, the HDMI output is not accepted by one of my other devices -- a Blackmagic Design Hyperdeck Studio HD Plus. The video cuts to black every couple of seconds or so. I also have an Amiko receiver, and the Blackmagic device has no problem with that.

Second, at least a few of the commands from the remote are the same as what's used by my DVDO HDMI switcher. Pressing the red button for instance turns the switcher off.

Any suggestions on solutions to these incompatibilities? Thanks!
 
Last edited by a moderator:
In the Edision A/V settings menu, you can configure the Mode for a number of different resolutions. Is this setting correct for the Blackmagic? I think the Edision default is 720p. I use 1080p to match with my Sony TV. You can also set the Refresh rate.

There are HDMI settings I don't understand but through trial and error, I've learned in my case I must enable the HDMI-CEC setup menu which is disabled by default. The default settings inside that menu are fine for me. In A/V settings, I also must enable "Use HDMI pre-emphasis". If I don't set these accordingly, after a reboot, I get a black screen.

You can program/change programming for the different colour keys as you wish. Not sure if this will help in the case of the last problem.
 
Thanks for the response. The Blackmagic recorder will accept a multitude of resolutions/frame rates. The only one that it "likes" from the Edision is 480i, which obviously is not something I'd want to use. Curiously, I found that if I try to switch the Edision to 1080p, the receiver immediately crashes and reboots. This happens regardless of whether I am connected to the Blackmagic recorder, or a TV. Pic of the crash screen below.

I tried changing some of the HDMI settings with no luck so far.

Thanks for the tip on the buttons -- I'll mess around with that.
 

Attachments

  • Crash.png
    Crash.png
    65.1 KB · Views: 156
TNAP 4.1. Here's a screenshot of the "About" menu:
 

Attachments

  • HyperDeck_0005-0001.png
    HyperDeck_0005-0001.png
    239.3 KB · Views: 159
If the Edision is connected directly to the TV does the issue still occur and crash? I know my Mio doesn't work well with older presumably HDMI 1.3 generic cables. Just not enough data can pass and artifacts are displayed at 1080i while 720p is fine.

What is the video refresh rate? If set at 50 Hz. and not 60 Hz. you may have a problem.

What video resolution does the Blackmagic device pass? When I had Orby, I used one of those HDMI video game recorder devices with a splitter to use as a DVR since my receiver was a basic unit. The recorder was limited to 720p. Not that much of Orby's programming was very high resolution anyway so it worked ok.
 
The Edision works fine when connected to a couple of different TVs, but still crashes if I try to select 1080p. Refresh rate is set to 60Hz. That said, I had no plan to use 1080p -- selecting that mode was strictly for testing purposes. 1080i/59.94 is my preferred setting.

As for the Blackmagic device, these are the supported resolutions. It will inhale most anything:

SD Video Standards​

525i59.94 NTSC, 625i50 PAL

HD Video Standards​

720p50, 720p59.94, 720p60
1080i50, 1080i59.94, 1080i60
1080p23.98, 1080p24, 1080p25, 1080p29.97, 1080p30, 1080p50, 1080p59.94, 1080p60, 1080PsF23.98, 1080PsF24, 1080PsF25, 1080PsF29.97, 1080PsF30

2K DCI Video Standards​

2Kp23.98 DCI, 2Kp24 DCI, 2Kp25 DCI, 2Kp29.97 DCI, 2Kp30 DCI

Ultra HD Video Standards​

2160p23.98, 2160p24, 2160p25, 2160p29.97, 2160p30
 
I would post this question on the LegitFTA forum. LegitFTA

El bandido is the developer of the TNAP image and he will likely want to view a copy of the crash log.

You indicated by email that you disabled the HDMI-CEC, this would have been my first suggestion. Am not aware of any issue that could cause a 1080p crash. Might benefit from reloading TNAP 4.1 or testing with another image.
 
Thanks Brian, I'll do that. As I also indicated in my email, one of the members here has indicated that he'd like the purchase the receiver, so I'll likely sell it soon. The remote codes that conflict with other devices in my system is really the bigger problem that likely can't be remedied.
 
OK, I have to take some responsibility here. In attempting to re-create the crash, I didn't notice that when toggling the resolution to 1080p, the refresh rate was changing to 50Hz. When I set it to 1080p/60, there's no crash. So, my fault for not noticing that.

As an experiment, I piped the 1080p signal into the Blackmagic and it still doesn't like it.
 

OTHER Channel

Edision OS Mio 4k stuck on "boot" and blue screen

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Who Read This Thread (Total Members: 4)