Avenger pll lnbf (1 Viewer)

Register Today to see less ads! It's Free!

dobiegillis

Thread Starter
SatelliteGuys Family
Sep 4, 2008
45
2
illinois
I am scratching my head over this one. I bought the Avenger pll lnbf 321s-2 for upgrade to my Openbox s10. I installed this puppy and am receiving 0 signal. Am i missing something here? I just figured i received a defective since by hooking my old lnbf back in place restored signals. I received the replacement Avenger and installed it to find the same results, no signal. I took my satellite meter to the dish to check the Avenger and have no signal with it also. Do you have any ideas guys?
 
Register Today to see less ads! It's Free!

77TA

SatelliteGuys Pro
Aug 27, 2013
562
50
Arkansas
Check the LO frequency setting. If it is a universal lnb it is probably 9750/10600 if standard it is most likely 10750. Also may need to turn on the 22khz setting if universal.
 

dobiegillis

Thread Starter
SatelliteGuys Family
Sep 4, 2008
45
2
illinois
There doesn't appear to be a choice of lnlb settings in this s10. It is either on or off. Old lnlb is a standard. Receiver set for 10750. Avenger lnlb is universal.
 

laurienicol

Member
Jan 18, 2014
14
1
Delta, BC
I just bought one too (Avenger PLL321S-2) and I also have Zero signal.
For $10 it was worth a try.
I've got the GloryStar setup (Geosat Pro 1200) with the GeoSat PLL. I put the GeoSat PLL unit back in, and everything is fine again.
I lined up the arrows on the Avenger just like the GeoSat

The present setting is 10750 and the 22 tone is on.
A previous post indicated that the LNB setting may have to be changed for the Avenger.
I'll try again
 

KE4EST

SatelliteGuys Is My Second Home
Staff member
HERE TO HELP YOU!
Lifetime Supporter
Aug 9, 2004
26,015
6,243
EM75xb
Yep change your LO to 10600 and it will most likely work then. :)
 
Register Today to see less ads! It's Free!

jorgek

SatelliteGuys Pro
Mar 11, 2013
1,214
221
Near Toronto
And you won't. I have 3 Avenger PLL LNBs and 1 GeoSatPro PLL. I don't see any difference other than I have a 33" dish which got dented. Aimed at 125W the Avenger manages to receive PBS and Montana. I can't get the GeoSat to do the same.
 
Register Today to see less ads! It's Free!

Users who are viewing this thread

Users Who Are Viewing This Thread (Total: 0, Members: 0, Guests: 0)

Top