Does anyone know if the Edision OS MIO 4K has DLNA capability?

Discussion in 'Android and Enigma/Linux Based STB Discussion' started by comfortably_numb, Apr 14, 2019.

  1. comfortably_numb

    comfortably_numb Topic Starter Dogs have owners, cats have staff Pub Member / Supporter

    Joined:
    Nov 30, 2011
    Posts:
    7,700
    Likes Received:
    8,081
    Location:
    Missouri/Kansas
    Just curious. It would be nice to be able to see my Edision's EHD on the network so I can easily move recorded files off of it to my PC's.
     
  2. primestar31

    primestar31 SatelliteGuys Master

    Joined:
    Mar 15, 2005
    Posts:
    8,286
    Likes Received:
    4,549
    Location:
    Beta Omicron Delta III
    I do that now, without DLNA, I move stuff around all the time. Just map the drive to \\osmio4k\media.

    Look under "Network" under Windows Explorer on your Windows pc, and you should see the Mio there. If so then map your drive as I said above.

    Be aware that each recording can have multiple files attached to it, as it picks up Metadata from the web. I've seen up to 5 per recording.
     
  3. comfortably_numb

    comfortably_numb Topic Starter Dogs have owners, cats have staff Pub Member / Supporter

    Joined:
    Nov 30, 2011
    Posts:
    7,700
    Likes Received:
    8,081
    Location:
    Missouri/Kansas
    For some reason I don't see it there. Is there a setting in the STB that I need to enable for it to be visible on the network?
     
  4. primestar31

    primestar31 SatelliteGuys Master

    Joined:
    Mar 15, 2005
    Posts:
    8,286
    Likes Received:
    4,549
    Location:
    Beta Omicron Delta III
    Yes, let me see if I can remember where they are. Give me a few minutes.

    With NASDGR:

    Menu - Setup - System - Expert Settings - Network - LAN Connection (I'm using ethernet, choose WLAN if you are wireless on your Mio) - NetworkBrowser - it'll scan and find your network devices on whatever IP address they are on. Select the one for your pc. IF your pc is password protected, you'll have to add your login id and password.

    After I did that, the Mio appeared on my pc.

    You need to play more with your image. Put a duplicate on one of the other slots, and have at it. Press buttons, in various screens, and see what happens. IF you hose it all up, you'll not mess up your "working" image. But you'll learn all sorts of things! LOL
     
    #4 primestar31, Apr 14, 2019
    Last edited: Apr 14, 2019
    comfortably_numb and jaytee4320 like this.
  5. comfortably_numb

    comfortably_numb Topic Starter Dogs have owners, cats have staff Pub Member / Supporter

    Joined:
    Nov 30, 2011
    Posts:
    7,700
    Likes Received:
    8,081
    Location:
    Missouri/Kansas
    Well, the Edision sees my PC's, but my PC's won't see the Edision. I double checked that I was entering my computer username/password correctly but no joy.
     
  6. primestar31

    primestar31 SatelliteGuys Master

    Joined:
    Mar 15, 2005
    Posts:
    8,286
    Likes Received:
    4,549
    Location:
    Beta Omicron Delta III
    REBOOT! Power-plug pull. lol

    For that matter, reboot your pc also.
     
  7. comfortably_numb

    comfortably_numb Topic Starter Dogs have owners, cats have staff Pub Member / Supporter

    Joined:
    Nov 30, 2011
    Posts:
    7,700
    Likes Received:
    8,081
    Location:
    Missouri/Kansas
    Must be an OpenVIX issue. Booted up TNAP and the PC found the Edision without even having to browse the network on the STB or enter any credentials!
     
    primestar31 likes this.
  8. primestar31

    primestar31 SatelliteGuys Master

    Joined:
    Mar 15, 2005
    Posts:
    8,286
    Likes Received:
    4,549
    Location:
    Beta Omicron Delta III
    Sounds like a sign as to which image you should stay on. As for OpenVix, I have that image and can see the Mio from my pc. I had to do all the same network things I laid out on each image, to get it working. But not sure why yours wouldn't work.
     
  9. voomvoom

    voomvoom SatelliteGuys Master

    Joined:
    May 18, 2004
    Posts:
    6,648
    Likes Received:
    20
    Location:
    Lizella, Georgia Republic
    What you should be able to do is, enter your IP for the MIO onto your PC's URL (or whatever it's called?)
    That should bring up the WEBIF page for the MIO, then click on Movies, that should bring up all the recordings in the MIO?
    Then for the movie you want to copy to the PC, click on the icon that looks like an old floppy. A permission box will pop-up...
    Set it to where you want to send it, then click YES

    Good Luck !!!

    Al
     
    primestar31 and comfortably_numb like this.
  10. comfortably_numb

    comfortably_numb Topic Starter Dogs have owners, cats have staff Pub Member / Supporter

    Joined:
    Nov 30, 2011
    Posts:
    7,700
    Likes Received:
    8,081
    Location:
    Missouri/Kansas
    That sounds a lot better than the network share option. File sharing on Windows 10 is very hit or miss, in my experience. Printer sharing works *some* of the time.
     
  11. arlo

    arlo SatelliteGuys Family

    Joined:
    Dec 4, 2016
    Posts:
    40
    Likes Received:
    27
    Location:
    North Eastern
    I'm actually able to see my mio in Win 10 Network. I see my external HDD and the Root directories.
    I can push and pull files either way on my PC. No login credentials even had to be populated.
    Running OpenATV 6.2. No actual tweaking was necessary. It's just there as OSMIO4K.

    The real kicker is why doesn't there exist a Linux, Enigma2, BDA type driver for these boxes.
    That alone would enable the use of Media Portal. To boot, Media Buddy would let us fairly easily build an EPG.
    My HDHomerun is running alongside MP on my Windows PC and Fire TV, Cube.
    Lucky to have open cable channels which the ITC ones come in flawlessly.
    I know a TBS and other DVB cards work with MP. And the HDHR Extend is on my LAN.

    The Webif/VLC way is a PITA....doable...but still a royal you-know-what.
     
    primestar31 likes this.

Separate names with a comma.

More...